summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/tong/tong-1.0.ebuild')
-rw-r--r--games-puzzle/tong/tong-1.0.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/games-puzzle/tong/tong-1.0.ebuild b/games-puzzle/tong/tong-1.0.ebuild
index 7b783263de71..3e609526a04e 100644
--- a/games-puzzle/tong/tong-1.0.ebuild
+++ b/games-puzzle/tong/tong-1.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tong/tong-1.0.ebuild,v 1.5 2008/02/29 19:29:34 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tong/tong-1.0.ebuild,v 1.6 2009/04/06 21:57:42 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Tetris and Pong in the same place at the same time"
@@ -14,14 +15,13 @@ KEYWORDS="amd64 ~ppc x86"
IUSE=""
DEPEND="media-libs/libsdl
- media-libs/sdl-image
- media-libs/sdl-mixer"
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PV}-makefile.patch"
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-makefile.patch" \
+ "${FILESDIR}/${P}-fps.patch"
sed -i \
-e "s:\"media/:\"${GAMES_DATADIR}/${PN}/media/:" \
media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
@@ -35,7 +35,7 @@ src_install() {
cp -r media/ "${D}/${GAMES_DATADIR}/${PN}" || die "cp failed"
dodoc CHANGELOG README making-of.txt CREDITS
- make_desktop_entry tong TONG ${PN}
+ make_desktop_entry tong TONG
doicon "${T}/${PN}.png"
prepgamesdirs
}