summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild')
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild
new file mode 100644
index 000000000000..a822314d0e73
--- /dev/null
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r1.ebuild,v 1.1 2006/04/19 20:30:24 tupone Exp $
+
+inherit games
+
+DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
+HOMEPAGE="http://cycojesus.free.fr/faire/coder/jouer/ng-star/"
+SRC_URI="http://cycojesus.free.fr/faire/coder/jouer/ng-star/files/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gentoo-path.patch
+ sed -i \
+ -e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \
+ -e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
+ configure
+}
+
+src_compile() {
+ ./configure \
+ --prefix "" \
+ --without-fltk2 || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS Changelog README TODO
+ prepgamesdirs
+}