summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/gtklife/gtklife-5.1.ebuild')
-rw-r--r--games-misc/gtklife/gtklife-5.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-misc/gtklife/gtklife-5.1.ebuild b/games-misc/gtklife/gtklife-5.1.ebuild
new file mode 100644
index 000000000000..4a4a5c837d78
--- /dev/null
+++ b/games-misc/gtklife/gtklife-5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/gtklife/gtklife-5.1.ebuild,v 1.1 2006/10/12 18:03:24 nyhm Exp $
+
+inherit eutils games
+
+DESCRIPTION="A Conway's Life simulator for Unix"
+HOMEPAGE="http://ironphoenix.org/tril/gtklife/"
+SRC_URI="http://ironphoenix.org/tril/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2"
+
+src_compile() {
+ egamesconf \
+ --with-gtk2 \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics patterns || die "doins failed"
+
+ newicon icon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} GtkLife
+
+ dohtml doc/*
+ dodoc AUTHORS README NEWS
+ prepgamesdirs
+}