summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild')
-rw-r--r--games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild50
1 files changed, 37 insertions, 13 deletions
diff --git a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
index cfd235410b44..1c69eb7a4cba 100644
--- a/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
+++ b/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild,v 1.5 2006/09/28 20:57:25 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ggz-gtk-client/ggz-gtk-client-0.0.13.ebuild,v 1.6 2006/10/11 15:35:26 nyhm Exp $
-inherit eutils games
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit autotools eutils games
DESCRIPTION="The gtk client for the GGZ Gaming Zone"
HOMEPAGE="http://www.ggzgamingzone.org/"
@@ -12,26 +14,48 @@ SRC_URI="http://ftp.belnet.be/packages/ggzgamingzone/ggz/${PV}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-amd64 ppc x86"
-IUSE=""
+IUSE="gaim"
+RESTRICT="userpriv"
-DEPEND="~dev-games/ggz-client-libs-0.0.13
- =x11-libs/gtk+-2*"
+RDEPEND="~dev-games/ggz-client-libs-${PV}
+ =x11-libs/gtk+-2*
+ virtual/libintl
+ gaim? ( =net-im/gaim-1.5* )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
-src_compile() {
- local myconf="--enable-gtk=gtk2"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gaim.patch
+
+ sed -i '/desktopdir/s:$(datadir):/usr/share:' \
+ Makefile.am || die "sed Makefile.am failed"
+
+ eautoreconf
+
+ sed -i 's:$(includedir):/usr/include:' \
+ ggz-gtk/Makefile.in || die "sed Makefile.in failed"
+ sed -i '/locale/s:$(prefix):/usr:' \
+ po/Makefile.in || die "sed configure.ac failed"
+}
+
+src_compile() {
egamesconf \
- --enable-gtk=gtk2 \
--disable-debug \
+ $(use_enable gaim) \
|| die
- emake || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ dodir /usr/include
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rmdir "${D}/${GAMES_PREFIX}"/include
+
dodoc AUTHORS ChangeLog NEWS QuickStart.GGZ README* TODO
- domenu ${D}/usr/share/games/applications/ggz-gtk.desktop
- rm -rf ${D}/usr/share/games
prepgamesdirs
}
-