summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/stepmania')
-rw-r--r--games-action/stepmania/ChangeLog16
-rw-r--r--games-action/stepmania/Manifest3
-rw-r--r--games-action/stepmania/files/digest-stepmania-200307051
-rw-r--r--games-action/stepmania/stepmania-20030705.ebuild33
4 files changed, 53 insertions, 0 deletions
diff --git a/games-action/stepmania/ChangeLog b/games-action/stepmania/ChangeLog
new file mode 100644
index 000000000000..04d6ffa117fd
--- /dev/null
+++ b/games-action/stepmania/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-games/stepmania
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/stepmania/ChangeLog,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+stepmania-20030705
+ 01 Sept 2003; Joshua Charles Campbell <warpzero@gentoo.org> ChangeLog stepmania-20030705.ebuild:
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
+ 04 Sep 2003; Michael Sterrett <msterret@gentoo.org>
+ stepmania-20030705.ebuild:
+ tidy; inherit games
+
diff --git a/games-action/stepmania/Manifest b/games-action/stepmania/Manifest
new file mode 100644
index 000000000000..f5e8334534e7
--- /dev/null
+++ b/games-action/stepmania/Manifest
@@ -0,0 +1,3 @@
+MD5 806e12ec2b7baa4cd5cd8d35a0f16ebe ChangeLog 817
+MD5 fb37887459159dd78c99896d979a77ce stepmania-20030705.ebuild 930
+MD5 f9521504525510bb9d2c9bd66ef6d946 files/digest-stepmania-20030705 75
diff --git a/games-action/stepmania/files/digest-stepmania-20030705 b/games-action/stepmania/files/digest-stepmania-20030705
new file mode 100644
index 000000000000..41d9ae34fffc
--- /dev/null
+++ b/games-action/stepmania/files/digest-stepmania-20030705
@@ -0,0 +1 @@
+MD5 2a3990d2785b4059fe0075411f87cebc stepmania-cvs-5Jul03.tar.bz2 14555072
diff --git a/games-action/stepmania/stepmania-20030705.ebuild b/games-action/stepmania/stepmania-20030705.ebuild
new file mode 100644
index 000000000000..58ce210a75f9
--- /dev/null
+++ b/games-action/stepmania/stepmania-20030705.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/stepmania/stepmania-20030705.ebuild,v 1.1 2003/09/10 19:29:16 vapier Exp $
+
+inherit games
+
+MY_PV="cvs-5Jul03"
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An advanced DDR simulator"
+HOMEPAGE="http://www.stepmania.com/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/libmad
+ media-libs/libogg
+ media-libs/libvorbis"
+
+src_install() {
+ dogamesbin ${S}/src/stepmania
+ cp -r ${S}/Announcers ${S}/BGAnimations ${S}/CDTitles ${S}/Cache \
+ ${S}/Characters ${S}/Courses ${S}/Data ${S}/Docs ${S}/NoteSkins \
+ ${S}/RandomMovies ${S}/Songs ${S}/Themes ${S}/Utils \
+ ${S}/Visualizations ${D}/usr/games/stepmania/
+}