summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diffball/diffball-0.6_pre2.ebuild')
-rw-r--r--dev-util/diffball/diffball-0.6_pre2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/diffball/diffball-0.6_pre2.ebuild b/dev-util/diffball/diffball-0.6_pre2.ebuild
new file mode 100644
index 000000000000..ff5e502a5c39
--- /dev/null
+++ b/dev-util/diffball/diffball-0.6_pre2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/diffball/diffball-0.6_pre2.ebuild,v 1.1 2004/09/17 08:56:34 ferringb Exp $
+
+IUSE=""
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="http://sourceforge.net/projects/diffball"
+SRC_URI="mirror://sourceforge/diffball/diffball-${PV}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc alpha ~hppa ~mips ~amd64 ~ia64"
+
+DEPEND=">=dev-libs/openssl-0.9.6j
+ >=dev-libs/popt-1.7
+ >=sys-libs/zlib-1.1.4
+ >=app-arch/bzip2-1.0.2"
+
+src_compile() {
+ econf $(use_enable debug asserts) || die "econf failed"
+ emake || die "emake failed"
+ einfo "yo yo yo"
+}
+
+src_install() {
+ cd ${S}
+ einstall || die
+
+ dodoc AUTHORS ChangeLog README TODO
+}