summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bitkeeper/bitkeeper-3.0.1.ebuild')
-rw-r--r--dev-util/bitkeeper/bitkeeper-3.0.1.ebuild54
1 files changed, 26 insertions, 28 deletions
diff --git a/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
index 77a3492e7872..f4f5c6353716 100644
--- a/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
+++ b/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild
@@ -1,55 +1,53 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild,v 1.2 2003/02/13 11:47:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bitkeeper/bitkeeper-3.0.1.ebuild,v 1.3 2003/02/17 04:05:58 vapier Exp $
-DESCRIPTION="BitKeeper is a scalable configuration management system."
-SRC_URI=""
-HOMEPAGE="http://www.bitkeeper.com"
+DESCRIPTION="scalable configuration management system"
+HOMEPAGE="http://www.bitkeeper.com/"
+SRC_URI="x86? ( bk-3.0.1-x86-glibc22-linux.bin )
+ ppc? ( bk-3.0.1-powerpc-glibc21-linux.bin )
+ sparc? ( bk-3.0.1-sparc-glibc21-linux.bin )
+ alpha? ( bk-3.0.1-alpha-glibc21-linux.bin )
+ arm? ( bk-3.0.1-arm-glibc21-linux.bin )
+ hppa? ( bk-3.0.1-hppa-glibc22-linux.bin )"
SLOT="0"
LICENSE="BKL"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa"
-DEPEND=">=virtual/glibc-2.2
- >=dev-lang/tcl-8.3.3
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-lang/tcl-8.3.3
X? ( >=dev-lang/tk-8.3.3 )"
-# I'm not sure what the official way to do this is...
-use 'x86' >/dev/null && A="bk-3.0.1-x86-glibc22-linux.bin"
-use 'ppc' >/dev/null && A="bk-3.0.1-powerpc-glibc21-linux.bin"
-use 'sparc' >/dev/null && A="bk-3.0.1-sparc-glibc21-linux.bin"
-use 'alpha' >/dev/null && A="bk-3.0.1-alpha-glibc21-linux.bin"
-
-pkg_setup() {
- if [ ! -f ${DISTDIR}/${A} ] ; then
- eerror "You need to perform the following steps to install this package:"
- eerror "- Sign up at ${HOMEPAGE}"
- eerror "- Check your mail and visit the download location"
- eerror "- Download ${A} and place it in ${DISTDIR}"
- eerror "- emerge this package again"
- die "package must be downloaded"
- fi
+RESTRICT="fetch"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ eerror "You need to perform the following steps to install this package:"
+ eerror " - Sign up at ${HOMEPAGE}"
+ eerror " - Check your mail and visit the download location"
+ eerror " - Download ${A} and place it in ${DISTDIR}"
+ eerror " - emerge this package again"
}
src_unpack() {
- mkdir ${S}
cp ${DISTDIR}/${A} ${S}/${A}
chmod 755 ${S}/${A}
echo 'none' | ${S}/${A} > ${S}/output 2>/dev/null
installer=`sed -n -e "s/Installation script: \(.*\)/\1/p" ${S}/output`
archive=`sed -n -e "s/Gzipped tar archive: \(.*\)/\1/p" ${S}/output`
- mv $installer ${S}/installer
- mv $archive ${S}/archive
+ mv ${installer} ${S}/installer
+ mv ${archive} ${S}/archive
}
src_install() {
dodir /opt /etc/env.d
- cd ${D}/opt && tar -xzpf ${S}/archive
- mv ${D}/opt/bitkeeper ${D}/opt/${P}
+ tar -xzpf ${S}/archive
+ mv bitkeeper ${D}/opt/${P}
chown -R root:root ${D}/opt/${P}
chmod -R u+w,go-w ${D}/opt/${P}
cat <<EOF >${D}/etc/env.d/10bitkeeper
-# Generated by ${P}.ebuild
PATH=/opt/${P}
ROOTPATH=/opt/${P}
MANPATH=/opt/${P}/man