summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclperl/tclperl-3.1.ebuild')
-rw-r--r--dev-tcltk/tclperl/tclperl-3.1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-tcltk/tclperl/tclperl-3.1.ebuild b/dev-tcltk/tclperl/tclperl-3.1.ebuild
index ca5bdc85ba65..4fa8ed552d35 100644
--- a/dev-tcltk/tclperl/tclperl-3.1.ebuild
+++ b/dev-tcltk/tclperl/tclperl-3.1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclperl/tclperl-3.1.ebuild,v 1.1 2004/10/21 15:35:06 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclperl/tclperl-3.1.ebuild,v 1.2 2004/10/26 13:50:18 vapier Exp $
+
+inherit toolchain-funcs
DESCRIPTION="a Perl package for Tcl"
HOMEPAGE="http://jfontain.free.fr/tclperl.htm"
SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64 ~ppc"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
DEPEND=">=dev-lang/tcl-8.3.3
@@ -18,16 +20,15 @@ src_compile() {
perl Makefile.PL || die
make OPTIMIZE="${CFLAGS}" Tcl.o || die
- [ -z "${CC}" ] && CC=gcc
- ${CC} -shared ${CFLAGS} -o tclperl.so.${PV} -fPIC -DUSE_TCL_STUBS \
+ $(tc-getCC) -shared ${CFLAGS} -o tclperl.so.${PV} -fPIC -DUSE_TCL_STUBS \
tclperl.c tclthread.c `perl -MExtUtils::Embed -e ccopts -e ldopts` \
/usr/lib/libtclstub`echo 'puts $tcl_version' | tclsh`.a Tcl.o || die
}
src_install() {
- insinto /usr/lib/tclperl
- doins tclperl.so.${PV}
- doins pkgIndex.tcl
+ exeinto /usr/lib/tclperl
+ doexe tclperl.so.${PV} || die "lib"
+ doexe pkgIndex.tcl || die "tcl"
dodoc CHANGES INSTALL README
dohtml tclperl.htm