summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tilt/tilt-1.3.ebuild')
-rw-r--r--dev-ruby/tilt/tilt-1.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/tilt/tilt-1.3.ebuild b/dev-ruby/tilt/tilt-1.3.ebuild
new file mode 100644
index 000000000000..4ea2e61fbbb2
--- /dev/null
+++ b/dev-ruby/tilt/tilt-1.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/tilt-1.3.ebuild,v 1.1 2011/04/30 07:20:24 graaff Exp $
+
+EAPI=2
+
+# jruby fails tests due to missing weakling, required by nokogiri.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thin interface over a Ruby template engines to make their usage as generic as possible."
+HOMEPAGE="http://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0"
+
+# Tests fail when markaby is not new enough, but it's optional.
+DEPEND="${DEPEND} !<dev-ruby/markaby-0.6.9-r1"
+RDEPEND="${RDEPEND}"