summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionmailer/actionmailer-4.0.13.ebuild')
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.13.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.13.ebuild
new file mode 100644
index 000000000000..5b8a7ef6b90a
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.0.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.13.ebuild,v 1.1 2015/01/07 07:05:21 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+
+ # Add json to Gemfile to fix mime-types not doing this itself.
+ sed -e '5igem "json"' -i ../Gemfile || die
+}