summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dateutil/python-dateutil-1.5.ebuild')
-rw-r--r--dev-python/python-dateutil/python-dateutil-1.5.ebuild39
1 files changed, 25 insertions, 14 deletions
diff --git a/dev-python/python-dateutil/python-dateutil-1.5.ebuild b/dev-python/python-dateutil/python-dateutil-1.5.ebuild
index e717109c2114..1b260bde9e56 100644
--- a/dev-python/python-dateutil/python-dateutil-1.5.ebuild
+++ b/dev-python/python-dateutil/python-dateutil-1.5.ebuild
@@ -1,35 +1,39 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-1.5.ebuild,v 1.6 2011/06/07 11:22:55 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-dateutil/python-dateutil-1.5.ebuild,v 1.7 2011/11/26 16:26:21 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*-jython"
-inherit distutils eutils
+inherit distutils
-DESCRIPTION="dateutil datetime math and logic library for python"
+DESCRIPTION="Extensions to the standard Python datetime module"
HOMEPAGE="http://labix.org/python-dateutil http://pypi.python.org/pypi/python-dateutil"
SRC_URI="http://labix.org/download/python-dateutil/${P}.tar.gz"
-LICENSE="PSF-2.3"
-SLOT="0"
+LICENSE="PSF-2"
+SLOT="python-2"
KEYWORDS="amd64 ia64 ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-DOCS="NEWS README"
+IUSE="examples"
-DEPEND="dev-python/setuptools"
RDEPEND="sys-libs/timezone-data"
-RESTRICT_PYTHON_ABIS="3.*"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+DOCS="NEWS README"
PYTHON_MODNAME="dateutil"
src_prepare() {
- epatch "${FILESDIR}/${PN}-1.4.1-locale.patch"
+ distutils_src_prepare
# Use zoneinfo in /usr/share/zoneinfo.
sed -e "s/zoneinfo.gettz/gettz/g" -i test.py || die "sed failed"
+
+ # Fix parsing of date in non-English locales.
+ sed -e 's/commands.getoutput("date")/commands.getoutput("LC_ALL=C date")/' -i example.py
}
src_test() {
@@ -41,7 +45,14 @@ src_test() {
src_install() {
distutils_src_install
- insinto /usr/share/doc/${PF}/examples
- doins example.py sandbox/*.py
- rm -f "${ED}"usr/lib*/python*/site-packages/dateutil/zoneinfo/*.tar.*
+
+ delete_zoneinfo() {
+ rm -f "${ED}$(python_get_sitedir)/dateutil/zoneinfo/"*.tar.*
+ }
+ python_execute_function -q delete_zoneinfo
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example.py sandbox/*.py
+ fi
}