summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild')
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild
new file mode 100644
index 000000000000..97f181001ae1
--- /dev/null
+++ b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild,v 1.1 2007/03/20 18:36:50 chtekk Exp $
+
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-php/PEAR-Log-1.8.7-r1"
+
+S="${WORKDIR}/propel_runtime-${PV/_/}"
+
+need_php_by_category
+
+pkg_setup() {
+ has_php
+
+ # We need PDO and a few other things
+ require_pdo
+ require_php_with_use reflection spl xml xsl
+}