summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild b/dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild
new file mode 100644
index 000000000000..4f9690b67d4f
--- /dev/null
+++ b/dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.4.0_rc1.ebuild,v 1.1 2005/06/13 19:32:58 sebastian Exp $
+
+SRC_URI_BASE="http://qa.php.net/~derick"
+PHPSAPI="cgi"
+inherit php-sapi eutils
+
+DESCRIPTION="PHP CGI"
+SLOT="0"
+IUSE="${IUSE} force-cgi-redirect"
+KEYWORDS="~x86 ~sparc ~alpha ~hppa ~ppc ~ia64 ~amd64 ~mips"
+
+# for this revision only
+PDEPEND=">=${PHP_PROVIDER_PKG}-4.3.11"
+PROVIDE="${PROVIDE} virtual/httpd-php"
+
+src_unpack() {
+ php-sapi_src_unpack
+
+ # Bug 88756
+ use flash && epatch ${FILESDIR}/php-4.3.11-flash.patch
+
+ # Bug 88795
+ use gmp && epatch ${FILESDIR}/php-4.3.11-gmp.patch
+}
+
+src_compile() {
+ # CLI needed to build stuff
+ myconf="${myconf} \
+ --enable-cgi \
+ --enable-cli \
+ --enable-fastcgi"
+
+ if use force-cgi-redirect; then
+ myconf="${myconf} --enable-force-cgi-redirect"
+ fi
+
+ php-sapi_src_compile
+}
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php-sapi_src_install
+
+ rm -f ${D}/usr/bin/php
+ # rename binary
+ newbin ${S}/sapi/cgi/php php-cgi
+}
+
+pkg_postinst() {
+ php-sapi_pkg_postinst
+ einfo "This is a CGI only build."
+}