summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/ChangeLog9
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.720.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.730.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.770.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.790.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.800.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.810.0.ebuild59
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-1.820.0.ebuild59
9 files changed, 8 insertions, 473 deletions
diff --git a/dev-perl/XML-LibXML/ChangeLog b/dev-perl/XML-LibXML/ChangeLog
index b659c184a02d..1f0753e45896 100644
--- a/dev-perl/XML-LibXML/ChangeLog
+++ b/dev-perl/XML-LibXML/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/XML-LibXML
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.111 2011/07/25 09:04:07 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/ChangeLog,v 1.112 2011/07/29 12:31:54 tove Exp $
+
+ 29 Jul 2011; Torsten Veller <tove@gentoo.org> -XML-LibXML-1.720.0.ebuild,
+ -XML-LibXML-1.730.0.ebuild, -XML-LibXML-1.750.0.ebuild,
+ -XML-LibXML-1.770.0.ebuild, -XML-LibXML-1.790.0.ebuild,
+ -XML-LibXML-1.800.0.ebuild, -XML-LibXML-1.810.0.ebuild,
+ -XML-LibXML-1.820.0.ebuild:
+ Cleanup
*XML-LibXML-1.840.0 (25 Jul 2011)
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.720.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.720.0.ebuild
deleted file mode 100644
index d83bc808e9a2..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.720.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.720.0.ebuild,v 1.1 2011/06/17 18:32:57 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.72
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.730.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.730.0.ebuild
deleted file mode 100644
index 5b21deb58485..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.730.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.730.0.ebuild,v 1.1 2011/06/20 16:47:14 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.73
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild
deleted file mode 100644
index 2b399df62a2f..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.750.0.ebuild,v 1.1 2011/06/25 08:14:20 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.75
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.770.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.770.0.ebuild
deleted file mode 100644
index 7305f0f7d01c..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.770.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.770.0.ebuild,v 1.1 2011/07/06 12:41:00 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.77
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.790.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.790.0.ebuild
deleted file mode 100644
index 9db540797459..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.790.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.790.0.ebuild,v 1.1 2011/07/09 07:40:13 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.79
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.800.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.800.0.ebuild
deleted file mode 100644
index ee13e805601f..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.800.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.800.0.ebuild,v 1.1 2011/07/14 14:00:51 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.80
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.810.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.810.0.ebuild
deleted file mode 100644
index 9cf2c49101a3..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.810.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.810.0.ebuild,v 1.1 2011/07/18 10:47:47 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.81
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}
diff --git a/dev-perl/XML-LibXML/XML-LibXML-1.820.0.ebuild b/dev-perl/XML-LibXML/XML-LibXML-1.820.0.ebuild
deleted file mode 100644
index f5f8de33ca71..000000000000
--- a/dev-perl/XML-LibXML/XML-LibXML-1.820.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-LibXML/XML-LibXML-1.820.0.ebuild,v 1.1 2011/07/21 17:43:44 tove Exp $
-
-EAPI=4
-
-MODULE_AUTHOR=SHLOMIF
-MODULE_VERSION=1.82
-inherit perl-module
-
-DESCRIPTION="A Perl module to parse XSL Transformational sheets using gnome's libXSLT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=">=dev-perl/XML-SAX-0.12
- >=dev-libs/libxml2-2.6.21
- >=dev-perl/XML-NamespaceSupport-1.07"
-RDEPEND="${DEPEND}
- !dev-perl/XML-LibXML-Common"
-
-SRC_TEST="do"
-
-# rac can't discern any difference between the build with or without
-# this, and if somebody wants to reactivate it, get it out of global
-# scope.
-#export PERL5LIB=`perl -e 'print map { ":$ENV{D}/$_" } @INC'`
-mytargets="pure_install doc_install"
-
-src_compile() {
- export SKIP_SAX_INSTALL=1
- perl-module_src_compile
-}
-
-pkg_postinst() {
- pkg_update_parser add XML::LibXML::SAX::Parser
- pkg_update_parser add XML::LibXML::SAX
-}
-
-pkg_postrm() {
- pkg_update_parser remove XML::LibXML::SAX::Parser
- pkg_update_parser remove XML::LibXML::SAX
-}
-
-pkg_update_parser() {
- # pkg_update_parser [add|remove] $parser_module
- local action=$1
- local parser_module=$2
-
- if [[ "$ROOT" = "/" ]] ; then
- einfo "Update Parser: $1 $2"
- perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
- || ewarn "Update Parser: $1 $2 failed"
- else
- elog "To $1 $2 run:"
- elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
- fi
-}