summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/pomap/pomap-2.9.4.ebuild')
-rw-r--r--dev-ml/pomap/pomap-2.9.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/pomap/pomap-2.9.4.ebuild b/dev-ml/pomap/pomap-2.9.4.ebuild
new file mode 100644
index 000000000000..319dbb1ca4eb
--- /dev/null
+++ b/dev-ml/pomap/pomap-2.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-2.9.4.ebuild,v 1.1 2004/08/08 09:28:17 mattam Exp $
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://www.ai.univie.ac.at/~markus/home/ocaml_sources.html"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.06
+ >=dev-ml/findlib-0.8"
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_compile() {
+ emake all || die
+}
+
+src_install () {
+ # which directory does the lib go into?
+ destdir=`ocamlfind printconf destdir`
+
+ # install
+ mkdir -p ${D}${destdir} || die
+ make OCAMLFIND_DESTDIR=${D}${destdir} \
+ OCAMLFIND_LDCONF=dummy install || die
+
+ # install documentation
+ dodoc LICENSE README VERSION Changes
+
+ #install examples
+ mv ${S}/examples/ ${D}/usr/share/doc/${PF}/
+}