summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-aspectl/ChangeLog10
-rw-r--r--dev-lisp/cl-aspectl/Manifest3
-rw-r--r--dev-lisp/cl-aspectl/cl-aspectl-0.6.3.ebuild29
-rw-r--r--dev-lisp/cl-aspectl/files/digest-cl-aspectl-0.6.31
-rw-r--r--dev-lisp/cl-aspectl/metadata.xml26
5 files changed, 69 insertions, 0 deletions
diff --git a/dev-lisp/cl-aspectl/ChangeLog b/dev-lisp/cl-aspectl/ChangeLog
new file mode 100644
index 000000000000..9093fd253064
--- /dev/null
+++ b/dev-lisp/cl-aspectl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-aspectl
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aspectl/ChangeLog,v 1.1 2004/10/19 05:22:19 mkennedy Exp $
+
+*cl-aspectl-0.6.3 (18 Oct 2004)
+
+ 18 Oct 2004; <mkennedy@gentoo.org> +metadata.xml,
+ +cl-aspectl-0.6.3.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-aspectl/Manifest b/dev-lisp/cl-aspectl/Manifest
new file mode 100644
index 000000000000..9a9b3a049858
--- /dev/null
+++ b/dev-lisp/cl-aspectl/Manifest
@@ -0,0 +1,3 @@
+MD5 1032a23ac3d2f1df81e293716f86fd01 cl-aspectl-0.6.3.ebuild 799
+MD5 6310c8b01587b6100d7a50443ee27454 metadata.xml 820
+MD5 d44596c6db0d930ab6246b8d6d5c22d0 files/digest-cl-aspectl-0.6.3 61
diff --git a/dev-lisp/cl-aspectl/cl-aspectl-0.6.3.ebuild b/dev-lisp/cl-aspectl/cl-aspectl-0.6.3.ebuild
new file mode 100644
index 000000000000..ff48499b8a91
--- /dev/null
+++ b/dev-lisp/cl-aspectl/cl-aspectl-0.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-aspectl/cl-aspectl-0.6.3.ebuild,v 1.1 2004/10/19 05:22:19 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="AspectL is a library that provides aspect-oriented extensions for Common Lisp/CLOS."
+HOMEPAGE="http://common-lisp.net/project/aspectl/"
+SRC_URI="http://common-lisp.net/project/aspectl/downloads/aspectl-${PV}.zip"
+
+LICENSE="CCPL-Attribution-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=aspectl
+
+S=${WORKDIR}/aspectl-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dohtml *.html *.css
+ docinto tests
+ dodoc tests/*
+}
diff --git a/dev-lisp/cl-aspectl/files/digest-cl-aspectl-0.6.3 b/dev-lisp/cl-aspectl/files/digest-cl-aspectl-0.6.3
new file mode 100644
index 000000000000..be8cf3e4edc7
--- /dev/null
+++ b/dev-lisp/cl-aspectl/files/digest-cl-aspectl-0.6.3
@@ -0,0 +1 @@
+MD5 403551e5a41e4e4b4d0ad1d88e86e800 aspectl-0.6.3.zip 35241
diff --git a/dev-lisp/cl-aspectl/metadata.xml b/dev-lisp/cl-aspectl/metadata.xml
new file mode 100644
index 000000000000..2376935ae6b1
--- /dev/null
+++ b/dev-lisp/cl-aspectl/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Linedit is a readline-style library written in Common Lisp that
+provides customizable line-editing features, licensed under a
+MIT-style license.
+
+Linedit uses UFFI for foreign bindings, so it is a least theoretically
+portable, though REPL-wrapping is currently SBCL specific. Features
+
+ * single-line text reader
+ * multi-line form reader
+ * completions on packages and symbols in current image
+ * completions on directories and filenames
+ * apropos-word and describe-word
+ * unlimited undo
+ * unlimited kill-ring
+ * unlimited history
+ * multiple histories
+ * use in REPL on SBCL
+ * paging
+ * fully customizable in CL
+</longdescription>
+</pkgmetadata>