summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-yacc/cl-yacc-0.2.ebuild')
-rw-r--r--dev-lisp/cl-yacc/cl-yacc-0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lisp/cl-yacc/cl-yacc-0.2.ebuild b/dev-lisp/cl-yacc/cl-yacc-0.2.ebuild
new file mode 100644
index 000000000000..422a9fe9de3c
--- /dev/null
+++ b/dev-lisp/cl-yacc/cl-yacc-0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-yacc/cl-yacc-0.2.ebuild,v 1.1 2006/01/31 17:43:27 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="CL-YACC is a LALR(1) parser generator for Common Lisp"
+HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/cl-yacc/
+ http://www.cliki.net/CL-Yacc"
+SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller
+ doc? ( sys-apps/texinfo )"
+
+CLPACKAGE="yacc"
+
+src_compile() {
+ if use doc; then
+ makeinfo cl-yacc.texi || die
+ fi
+}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ use doc && doinfo *.info*
+ dodoc README COPYING
+}