summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild')
-rw-r--r--dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild b/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild
new file mode 100644
index 000000000000..ad33e623a93a
--- /dev/null
+++ b/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-htmlgen/cl-htmlgen-1.2.27.20030919.ebuild,v 1.1 2003/10/15 16:48:01 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=1.2.27
+CVS_PV=2003.09.19
+
+DESCRIPTION="HTML generation library for Common Lisp programs"
+HOMEPAGE="http://packages.debian.org/unstable/web/cl-htmlgen.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-portable-aserve/cl-portable-aserve_${MY_PV}+cvs${CVS_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=htmlgen
+
+S=${WORKDIR}/cl-portable-aserve-${MY_PV}+cvs${CVS_PV}
+
+src_install() {
+ common-lisp-install aserve/htmlgen/*.cl aserve/htmlgen/*.asd
+ common-lisp-system-symlink
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE}
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE}
+} \ No newline at end of file