summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild')
-rw-r--r--dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild b/dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild
deleted file mode 100644
index f775f73c5e4a..000000000000
--- a/dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.7.0_pre20080120.ebuild,v 1.1 2008/01/24 21:50:30 armin76 Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="Netscape Portable Runtime"
-HOMEPAGE="http://www.mozilla.org/projects/nspr/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6 debug"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- mkdir build inst
- epatch "${FILESDIR}"/${PN}-4.6.1-config.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
- epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
- epatch "${FILESDIR}"/${PN}-4.7.0-prtime.patch
-}
-
-src_compile() {
- cd "${S}"/build
-
- if use amd64 || use ppc64 || use ia64 || use s390; then
- myconf="${myconf} --enable-64bit"
- else
- myconf=""
- fi
-
- if use ipv6; then
- myconf="${myconf} --enable-ipv6"
- fi
-
- myconf="${myconf} --libdir=/usr/$(get_libdir)/nspr"
-
- ECONF_SOURCE="../mozilla/nsprpub" econf \
- $(use_enable debug) \
- ${myconf} || die "econf failed"
- make || die
-}
-
-src_install () {
- # Their build system is royally fucked, as usual
- MINOR_VERSION=7
- cd "${S}"/build
- emake DESTDIR="${D}" install || die "emake install failed"
-
- cd "${D}"/usr/$(get_libdir)/nspr
- for file in *.so; do
- mv ${file} ${file}.${MINOR_VERSION}
- ln -s ${file}.${MINOR_VERSION} ${file}
- done
- # cope with libraries being in /usr/lib/nspr
- dodir /etc/env.d
- echo "LDPATH=/usr/$(get_libdir)/nspr" > "${D}/etc/env.d/08nspr"
-
- # install nspr-config
- dobin "${S}"/build/config/nspr-config
-
- # create pkg-config file
- insinto /usr/$(get_libdir)/pkgconfig/
- doins "${S}"/build/config/nspr.pc
-
- # Remove stupid files in /usr/bin
- rm "${D}"/usr/bin/{prerr.properties,nspr.pc}
-}