summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libelf/libelf-0.8.9.ebuild')
-rw-r--r--dev-libs/libelf/libelf-0.8.9.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/dev-libs/libelf/libelf-0.8.9.ebuild b/dev-libs/libelf/libelf-0.8.9.ebuild
index 6e5daad4f144..e679d8faf1d4 100644
--- a/dev-libs/libelf/libelf-0.8.9.ebuild
+++ b/dev-libs/libelf/libelf-0.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.9.ebuild,v 1.2 2007/06/20 04:17:29 kanaka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.9.ebuild,v 1.3 2007/10/19 13:22:38 uberlord Exp $
inherit multilib eutils
@@ -10,8 +10,8 @@ SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="debug nls"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug nls elibc_FreeBSD"
DEPEND="!dev-libs/elfutils
nls? ( sys-devel/gettext )"
@@ -19,7 +19,19 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-parallelmakefix.patch
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}"-parallelmakefix.patch
+
+ if use elibc_FreeBSD; then
+ # Stop libelf from stamping on the system nlist.h
+ sed -i -e 's:nlist.h::g' lib/Makefile.in || die
+
+ # Enable shared libs
+ sed -i \
+ -e 's:\*-linux\*\|\*-gnu\*:\*-linux\*\|\*-gnu\*\|\*-freebsd\*:' \
+ configure || die
+ fi
}
src_compile() {
@@ -33,9 +45,8 @@ src_compile() {
src_install() {
emake \
- prefix=${D}/usr \
- libdir=${D}usr/$(get_libdir) \
- includedir=${D}usr/include \
+ prefix="${D}"/usr \
+ libdir="${D}"usr/$(get_libdir) \
install \
install-compat || die "emake install failed"
dodoc ChangeLog VERSION README