summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/geoip/geoip-1.3.6.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.3.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.3.6.ebuild b/dev-libs/geoip/geoip-1.3.6.ebuild
new file mode 100644
index 000000000000..2f5774c5da59
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.3.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.3.6.ebuild,v 1.1 2004/08/16 07:58:22 eldad Exp $
+
+MY_P=${P/geoip/GeoIP}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ sys-libs/zlib"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}