summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild')
-rw-r--r--dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild b/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild
index 62dc1b67f062..c416edc6c093 100644
--- a/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild
+++ b/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild,v 1.8 2006/06/17 09:41:26 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-0.12.2.ebuild,v 1.9 2006/09/17 02:35:24 keri Exp $
inherit eutils
@@ -12,18 +12,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="doc glut iodbc opengl tcltk"
+IUSE="doc glut iodbc opengl tcl tk"
DEPEND="~dev-lang/mercury-0.12.2
sys-libs/ncurses
glut? ( virtual/glut )
iodbc? ( dev-db/libiodbc )
opengl? ( virtual/opengl )
- tcltk? ( =dev-lang/tk-8.4*
- || ( (
+ tcl? ( tk? (
+ =dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
x11-libs/libX11
- x11-libs/libXmu )
- virtual/x11 ) )"
+ x11-libs/libXmu ) )"
src_unpack() {
unpack ${A}
@@ -45,7 +45,7 @@ src_unpack() {
use iodbc && sed -i -e "s:moose:moose odbc:" Mmakefile
use glut && sed -i -e "s: lex : graphics/mercury_glut lex :" Mmakefile
- use tcltk && sed -i -e "s: lex : graphics/mercury_tcltk lex :" Mmakefile
+ use tcl && use tk && sed -i -e "s: lex : graphics/mercury_tcltk lex :" Mmakefile
use opengl && sed -i -e "s: lex : graphics/mercury_opengl lex :" Mmakefile
}
@@ -53,7 +53,7 @@ src_compile() {
mmake depend || die "mmake depend failed"
mmake || die "mmake failed"
- if use opengl && use tcltk ; then
+ if use opengl && use tcl && use tk ; then
cd "${S}"/graphics/mercury_opengl
cp ../mercury_tcltk/mtcltk.m ./
mmake -f Mmakefile.mtogl depend || die "mmake depend mtogl failed"
@@ -65,7 +65,7 @@ src_install() {
cd "${S}"
mmake INSTALL_PREFIX="${D}"/usr install || die "mmake install failed"
- if use opengl && use tcltk ; then
+ if use opengl && use tcl && use tk ; then
cd "${S}"/graphics/mercury_opengl
mv Mmakefile Mmakefile.opengl
mv Mmakefile.mtogl Mmakefile