summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild')
-rw-r--r--dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild b/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild
index 31a2985de393..6392399e716b 100644
--- a/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild
+++ b/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild,v 1.1 2012/06/14 17:53:31 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ekopath/ekopath-4.0.12.1_pre20120530.ebuild,v 1.2 2012/06/25 14:16:20 xarthisius Exp $
EAPI=4
@@ -21,6 +21,9 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+DEPEND="!!app-arch/rpm"
+RDEPEND=""
+
RESTRICT="mirror"
S=${WORKDIR}
@@ -34,18 +37,6 @@ QA_PREBUILT="
opt/${PN}/bin/subserver
opt/${PN}/bin/assign"
-pkg_pretend() {
- if has_version app-arch/rpm ; then
- ewarn "You have app-arch/rpm installed on your system. Therefore"
- ewarn "${PN} will fail to install due to sandbox violation."
- ewarn "As this cannot be fixed on distribution level, please use"
- ewarn "following workaround:"
- ewarn " emerge -C rpm && emerge -1 ${PN} && emerge -1 rpm"
- die
- fi
- echo opt/${PN}/lib/${MY_PV}/x8664/64/libeh.so
-}
-
src_unpack() {
cp "${DISTDIR}"/${A} "${S}" || die
chmod +x "${S}"/${P}.run
@@ -74,7 +65,7 @@ src_install() {
# The correct fix is in the assembly atomic-cxx.S, which we don't get
# See http://www.gentoo.org/proj/en/hardened/gnu-stack.xml
# Section 6. How to fix the stack (in practice)
- /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/4.0.11/x8664/64/libstl.so"
+ /usr/bin/scanelf -Xe "${D}/opt/ekopath/lib/${MY_PV}/x8664/64/libstl.so"
rm -rf "${D}"/opt/${PN}/uninstall || die
rm -rf "${D}"/opt/${PN}/bin/{pathdb,funclookup} || die #libtinfo