summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/nanoxml/nanoxml-2.2.1.ebuild')
-rw-r--r--dev-java/nanoxml/nanoxml-2.2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/nanoxml/nanoxml-2.2.1.ebuild b/dev-java/nanoxml/nanoxml-2.2.1.ebuild
new file mode 100644
index 000000000000..089f4adf4f54
--- /dev/null
+++ b/dev-java/nanoxml/nanoxml-2.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/nanoxml/nanoxml-2.2.1.ebuild,v 1.1 2004/09/21 19:36:44 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="NanoXML is a small non-validating parser for Java. "
+
+HOMEPAGE="http://nanoxml.sourceforge.net/"
+MY_P=NanoXML-${PV}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+DEPEND="virtual/jdk
+ dev-java/sax"
+RDEPEND="virtual/jre"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/ThirdParty/SAX
+ java-pkg_jar-from sax
+ cd ${S}
+ sed -e "s:/tmp/:${T}:" -i build.sh
+}
+
+src_compile() {
+ ./build.sh || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar Output/*.jar
+
+ use doc && dohtml -r Documentation/*
+}