summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/antlr/antlr-2.7.4.ebuild')
-rw-r--r--dev-java/antlr/antlr-2.7.4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-java/antlr/antlr-2.7.4.ebuild b/dev-java/antlr/antlr-2.7.4.ebuild
index 8c2b861a20d0..e04a77470e91 100644
--- a/dev-java/antlr/antlr-2.7.4.ebuild
+++ b/dev-java/antlr/antlr-2.7.4.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.4.ebuild,v 1.7 2005/02/05 15:59:53 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.4.ebuild,v 1.8 2005/07/09 15:58:08 axxo Exp $
inherit java-pkg gnuconfig
DESCRIPTION="A parser generator for Java and C++, written in Java"
SRC_URI="http://www.antlr.org/download/${P}.tar.gz"
HOMEPAGE="http://www.antlr.org"
-DEPEND=">=virtual/jdk-1.2"
+DEPEND=">=virtual/jdk-1.2
+ source? ( app-arch/zip )"
+RDEPEND=">=virtual/jre-1.2"
SLOT="0"
LICENSE="ANTLR"
KEYWORDS="~x86 ~amd64 ppc64"
-IUSE="doc examples"
+IUSE="doc examples source"
src_compile() {
gnuconfig_update
@@ -21,6 +23,7 @@ src_compile() {
src_install () {
java-pkg_dojar *.jar
+ use source && java-pkg_dosrc antlr
insinto /usr/share/antlr
doins extras/antlr-mode.el
@@ -35,5 +38,5 @@ src_install () {
cp -r examples/* ${D}/usr/share/doc/${PF}/examples
fi
cd lib/cpp
- make DESTDIR=$D install
+ make DESTDIR=$D install || die "failed to install"
}