summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/poker-eval/poker-eval-138.0.ebuild')
-rw-r--r--dev-games/poker-eval/poker-eval-138.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-games/poker-eval/poker-eval-138.0.ebuild b/dev-games/poker-eval/poker-eval-138.0.ebuild
new file mode 100644
index 000000000000..4db3fc4f9151
--- /dev/null
+++ b/dev-games/poker-eval/poker-eval-138.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/poker-eval/poker-eval-138.0.ebuild,v 1.1 2010/09/03 08:11:13 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="A fast C library for evaluating poker hands"
+HOMEPAGE="http://pokersource.info/"
+SRC_URI="http://download.gna.org/pokersource/sources/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --without-ccache \
+ $(use_enable static-libs static) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO WHATS-HERE
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+}