summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/libftdi/libftdi-0.16.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-0.16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-embedded/libftdi/libftdi-0.16.ebuild b/dev-embedded/libftdi/libftdi-0.16.ebuild
new file mode 100644
index 000000000000..8cb187362b51
--- /dev/null
+++ b/dev-embedded/libftdi/libftdi-0.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-0.16.ebuild,v 1.1 2009/05/12 22:21:07 vapier Exp $
+
+DESCRIPTION="Userspace access to FTDI USB interface chips"
+HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
+SRC_URI="http://www.intra2net.com/en/developer/libftdi/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/libusb-0.1.7"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # don't bother building examples as we dont want the binaries
+ # installed and the Makefile has broken install targets
+ sed -i '/^SUBDIRS =/s:examples::' Makefile.in
+
+ use doc || export ac_cv_path_DOXYGEN=true
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc ChangeLog README
+
+ if use doc ; then
+ doman doc/man/man3/*
+ dohtml doc/html/*
+ fi
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+}