summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild')
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild
deleted file mode 100644
index ec5907fc928a..000000000000
--- a/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.3.22-r1.ebuild,v 1.1 2013/01/12 18:59:35 titanofold Exp $
-
-EAPI="4"
-
-inherit versionator
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-
-RESTRICT="test"
-
-DESCRIPTION="PostgreSQL documentation"
-HOMEPAGE="http://www.postgresql.org/"
-SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
-LICENSE="POSTGRESQL"
-
-S=${WORKDIR}/postgresql-${PV}
-SLOT="$(get_version_component_range 1-2)"
-
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-src_unpack() {
- tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
-}
-
-src_install() {
- # Don't use ${PF} here as three packages
- # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
- local mypath=/usr/share/doc/postgresql-${SLOT}
-
- cd "${S}/doc"
-
- dodir ${mypath}/html
- tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
-
- insinto ${mypath}/FAQ_html
- doins src/FAQ/*
-
- insinto ${mypath}/sgml
- doins src/sgml/*.{sgml,dsl}
-
- insinto ${mypath}/sgml/ref
- doins src/sgml/ref/*.sgml
-
- insinto ${mypath}/TODO.detail
- doins TODO.detail/*
-
- fowners root:0 -R ${mypath}
-
- dodir /etc/eselect/postgresql/slots/${SLOT}
- echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
- "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
-}