summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.14.0.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.14.0.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild b/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild
deleted file mode 100644
index f0fd82fa16d3..000000000000
--- a/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.14.0.ebuild,v 1.6 2012/02/21 02:42:51 titanofold Exp $
-
-EAPI="4"
-
-WX_GTK_VER="2.8"
-
-inherit autotools multilib versionator wxwidgets
-
-DESCRIPTION="wxWidgets GUI for PostgreSQL."
-HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
-
-LICENSE="POSTGRESQL"
-KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
-SLOT="0"
-IUSE="debug"
-
-DEPEND="x11-libs/wxGTK:2.8[X,debug=]
- >=dev-db/postgresql-base-8.4.0
- >=dev-libs/libxml2-2.6.18
- >=dev-libs/libxslt-1.1"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- local pgslot=$(postgresql-config show)
-
- if [[ ${pgslot//.} < 84 ]] ; then
- eerror "PostgreSQL slot must be set to 8.4 or higher."
- eerror " postgresql-config set 8.4"
- die "PostgreSQL slot is not set to 8.4 or higher."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/ssl-detect-r1.patch"
- eautoreconf
-}
-
-src_configure() {
- econf --with-wx-version=2.8 \
- $(use_enable debug)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
-
- # icon location for the desktop file provided in pkg folder
- insinto /usr/share/pgadmin3
- doins "${S}/pgadmin/include/images/pgAdmin3.png"
-
- domenu "${S}/pkg/pgadmin3.desktop"
-
- # Fixing world-writable files
- fperms -R go-w /usr/share
-}