summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/freetds/freetds-0.62.3.ebuild')
-rw-r--r--dev-db/freetds/freetds-0.62.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-db/freetds/freetds-0.62.3.ebuild b/dev-db/freetds/freetds-0.62.3.ebuild
new file mode 100644
index 000000000000..bbc2c0085f46
--- /dev/null
+++ b/dev-db/freetds/freetds-0.62.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/freetds/freetds-0.62.3.ebuild,v 1.1 2004/04/24 18:56:02 robbat2 Exp $
+
+DESCRIPTION="Tabular Datastream Library"
+SRC_URI="http://ibiblio.org/pub/Linux/ALPHA/freetds/stable/${P}.tar.gz"
+HOMEPAGE="http://www.freetds.org/"
+IUSE="odbc"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~hppa ~alpha amd64 ia64"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ use odbc && myconf="--with-unixodbc=/usr"
+ econf --with-tdsver=7.0 ${myconf} --cache-file=${S}/config.cache
+ emake || die
+}
+
+src_install() {
+ mv ${S}/Makefile ${S}/Makefile.orig
+ sed -e 's/^DEFDIR = /DEFDIR = $(DESTDIR)/' \
+ ${S}/Makefile.orig > ${S}/Makefile
+ make DESTDIR=${D} install || die
+}