summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/ChangeLog8
-rw-r--r--app-text/sword/files/digest-sword-1.5.81
-rw-r--r--app-text/sword/metadata.xml3
-rw-r--r--app-text/sword/sword-1.5.8.ebuild43
-rw-r--r--app-text/sword/sword-1.5.8_pre1.ebuild4
5 files changed, 53 insertions, 6 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index f6432224dfcf..7ba153878c35 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sword
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.22 2005/04/24 11:43:30 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.23 2005/07/27 21:19:12 greg_g Exp $
+
+*sword-1.5.8 (27 Jul 2005)
+
+ 27 Jul 2005; Gregorio Guidi <greg_g@gentoo.org> metadata.xml,
+ sword-1.5.8_pre1.ebuild, +sword-1.5.8.ebuild:
+ New version (#94873). Ebuild cleanup.
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org>
sword-1.5.8_pre1.ebuild:
diff --git a/app-text/sword/files/digest-sword-1.5.8 b/app-text/sword/files/digest-sword-1.5.8
new file mode 100644
index 000000000000..d8397f8e0ec6
--- /dev/null
+++ b/app-text/sword/files/digest-sword-1.5.8
@@ -0,0 +1 @@
+MD5 c36398c84bfb044c0c66ef3ffcf29400 sword-1.5.8.tar.gz 1714799
diff --git a/app-text/sword/metadata.xml b/app-text/sword/metadata.xml
index b19770a9febf..ea458e49d038 100644
--- a/app-text/sword/metadata.xml
+++ b/app-text/sword/metadata.xml
@@ -2,9 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>no-herd</herd>
-<maintainer>
- <email>squinky86@gentoo.org</email>
-</maintainer>
<longdescription>
The SWORD Project is the CrossWire Bible Society's free Bible software
project. Its purpose is to create tools that allow programmers and Bible
diff --git a/app-text/sword/sword-1.5.8.ebuild b/app-text/sword/sword-1.5.8.ebuild
new file mode 100644
index 000000000000..7f4046f2e698
--- /dev/null
+++ b/app-text/sword/sword-1.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.8.ebuild,v 1.1 2005/07/27 21:19:12 greg_g Exp $
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl icu debug"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--without-lucene --with-zlib --with-conf
+ $(use_enable debug) $(use_with curl)"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
+
+ cp -R samples examples ${D}/usr/share/doc/${PF}/
+}
+
+pkg_postinst() {
+ echo
+ einfo "Check out http://www.crosswire.org/sword/modules/"
+ einfo "to download modules that you would like to use the"
+ einfo "library with. Follow module installation instructions"
+ einfo "found on the web or in /usr/share/doc/${PF}/INSTALL.gz."
+ echo
+}
diff --git a/app-text/sword/sword-1.5.8_pre1.ebuild b/app-text/sword/sword-1.5.8_pre1.ebuild
index 515c0669592b..9bb833463445 100644
--- a/app-text/sword/sword-1.5.8_pre1.ebuild
+++ b/app-text/sword/sword-1.5.8_pre1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.8_pre1.ebuild,v 1.7 2005/04/24 11:43:30 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.8_pre1.ebuild,v 1.8 2005/07/27 21:19:12 greg_g Exp $
-DESCRIPTION="Library for Bible reading software"
+DESCRIPTION="Library for Bible reading software."
HOMEPAGE="http://www.crosswire.org/sword/"
LICENSE="GPL-2"