summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/rarian/rarian-0.8.0-r1.ebuild')
-rw-r--r--app-text/rarian/rarian-0.8.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-text/rarian/rarian-0.8.0-r1.ebuild b/app-text/rarian/rarian-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..225bf190ea7c
--- /dev/null
+++ b/app-text/rarian/rarian-0.8.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/rarian/rarian-0.8.0-r1.ebuild,v 1.1 2008/03/30 21:06:20 compnerd Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A documentation metadata library"
+HOMEPAGE="http://www.freedesktop.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ !<app-text/scrollkeeper-9999"
+
+DOCS="ChangeLog NEWS README"
+
+GCONF=""
+
+src_unpack() {
+ # You cannot run src_unpack from gnome2; it will break the install by
+ # calling gnome2_omf_fix
+ unpack ${A}
+ cd "${S}"
+
+ # Only GNU getopt supports long options
+ # Scrollkeeper didn't support them, so we'll punt them for now
+ epatch "${FILESDIR}/${PN}-0.6.0-posix-getopt.patch"
+
+ epatch "${FILESDIR}/${PN}-0.8.0-info-segfault.patch"
+
+ elibtoolize ${ELTCONF}
+}