summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/man2html')
-rw-r--r--app-text/man2html/Manifest5
-rw-r--r--app-text/man2html/files/digest-man2html-1.5l-r11
-rw-r--r--app-text/man2html/man2html-1.5l-r1.ebuild71
3 files changed, 74 insertions, 3 deletions
diff --git a/app-text/man2html/Manifest b/app-text/man2html/Manifest
index 7e38c805d30e..fb294b0ef9f1 100644
--- a/app-text/man2html/Manifest
+++ b/app-text/man2html/Manifest
@@ -1,8 +1,7 @@
MD5 7908194426c45e3914f9dbe60b975e97 man2html-1.5l.ebuild 1564
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
-MD5 e2609f917b9796221074f7e061246973 ChangeLog 437
-MD5 0a642155bbe23ab82aa66d8ba2e25e82 man2html-1.5l-r1.ebuild 1643
-MD5 e9c1def259a8cb100c888443e563f61f .man2html-1.5l-r1.ebuild.swp 12288
+MD5 a82a51948b88243085492af4c21dcf4a ChangeLog 561
+MD5 3f2e1d4089ccdde78d121197e1e1411f man2html-1.5l-r1.ebuild 1824
MD5 a63bfea0511bb4ea9292d63dc11348b3 files/digest-man2html-1.5l 60
MD5 8907539a119c6fcb706af01a90e6923f files/man2html.cron 120
MD5 56100920b7436cf90ed14c82d9d6475e files/manwhatis-gentoo.patch 638
diff --git a/app-text/man2html/files/digest-man2html-1.5l-r1 b/app-text/man2html/files/digest-man2html-1.5l-r1
new file mode 100644
index 000000000000..1d4a35da11da
--- /dev/null
+++ b/app-text/man2html/files/digest-man2html-1.5l-r1
@@ -0,0 +1 @@
+MD5 07fa5ab41c39afcd59cdef5139ef563b man-1.5l.tar.gz 218249
diff --git a/app-text/man2html/man2html-1.5l-r1.ebuild b/app-text/man2html/man2html-1.5l-r1.ebuild
new file mode 100644
index 000000000000..98d72d0fe75e
--- /dev/null
+++ b/app-text/man2html/man2html-1.5l-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/man2html-1.5l-r1.ebuild,v 1.1 2003/12/27 13:32:15 twp Exp $
+
+inherit eutils webapp-apache
+webapp-detect || NO_HTTPD=1
+
+DESCRIPTION="Convert manual pages to HTML"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+SRC_URI="mirror://kernel/linux/utils/man/man-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips sparc x86"
+
+DEPEND="app-misc/glimpse
+ sys-apps/gawk
+ sys-apps/man"
+
+S=${WORKDIR}/man-${PV}
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_HTTPD}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/mansearch-gentoo.patch
+ epatch ${FILESDIR}/manwhatis-gentoo.patch
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/htdocs/:${HTTPD_ROOT}:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-bin/:${HTTPD_CGIBIN}:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-aux/:${HTTPD_CGIBIN/bin/aux}:g"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp-mkdirs
+
+ cd man2html
+ exeinto ${HTTPD_CGIBIN}/man
+ doexe scripts/cgi-bin/man/*
+ insinto ${HTTPD_CGIBIN/bin/aux}/man
+ doins scripts/cgi-aux/man/*
+ insinto /var/man2html
+ newins glimpse_filters .glimpse_filters
+ fperms 1777 /var/man2html
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/man2html.cron
+}
+
+pkg_postinst() {
+ einfo Run
+ einfo "\tebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo to complete installation.
+}
+
+pkg_config() {
+ einfo Running makewhatis
+ /usr/sbin/makewhatis
+ eend $?
+ einfo Running glimpseindex
+ /usr/bin/glimpseindex -z -H /var/man2html `man -w | tr : ' '`
+ eend $?
+ chmod 644 /var/man2html/.glimpse*
+ einfo Manual pages are available at http://localhost/cgi-bin/man/man2html
+}