summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libplist/libplist-1.2.ebuild')
-rw-r--r--app-pda/libplist/libplist-1.2.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-pda/libplist/libplist-1.2.ebuild b/app-pda/libplist/libplist-1.2.ebuild
deleted file mode 100644
index 9f0c39e62194..000000000000
--- a/app-pda/libplist/libplist-1.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libplist/libplist-1.2.ebuild,v 1.3 2010/06/02 17:36:22 arfrever Exp $
-
-EAPI=2
-inherit cmake-utils eutils multilib python
-
-DESCRIPTION="Support library to deal with Apple Property Lists (Binary & XML)"
-HOMEPAGE="http://matt.colyer.name/projects/iphone-linux/index.php?title=Main_Page"
-SRC_URI="http://cloud.github.com/downloads/JonathanBeck/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="test"
-
-RDEPEND="dev-libs/glib:2
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-lang/swig"
-
-src_prepare() {
- sed -e 's:-Werror::g' \
- -i swig/CMakeLists.txt || die "sed failed"
-}
-
-src_configure() {
- mycmakeargs="-DCMAKE_SKIP_RPATH=ON
- -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
- -DPYTHON_VERSION=$(python_get_version) VERBOSE=1
- "
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/plist
-}
-
-pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/plist
-}