summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libopensync/libopensync-0.39-r1.ebuild')
-rw-r--r--app-pda/libopensync/libopensync-0.39-r1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/app-pda/libopensync/libopensync-0.39-r1.ebuild b/app-pda/libopensync/libopensync-0.39-r1.ebuild
index 12468765201b..700f11b6551b 100644
--- a/app-pda/libopensync/libopensync-0.39-r1.ebuild
+++ b/app-pda/libopensync/libopensync-0.39-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39-r1.ebuild,v 1.1 2011/02/12 03:51:19 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39-r1.ebuild,v 1.2 2011/02/14 20:14:23 dirtyepic Exp $
EAPI="3"
@@ -16,7 +16,7 @@ SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
SLOT="0"
LICENSE="LGPL-2.1"
-IUSE="doc python" # test
+IUSE="debug doc python" # test
RDEPEND="dev-db/sqlite:3
>=dev-libs/glib-2.12:2
@@ -30,15 +30,12 @@ DEPEND="${RDEPEND}
python? ( >=dev-lang/swig-1.3.17 )"
# test? ( >=dev-libs/check-0.9.2 )"
-# 14% tests passed, 275 tests failed out of 321
-RESTRICT="test"
-
DOCS="AUTHORS CODING ChangeLog README"
+# Tests don't pass
+RESTRICT="test"
RESTRICT_PYTHON_ABIS="3.*"
-#CMAKE_VERBOSE="1"
-
src_prepare() {
# Has hardcoded python versions, use the module shipped with cmake instead
# bug #276220
@@ -53,7 +50,9 @@ src_configure() {
$(cmake-utils_use_build doc DOCUMENTATION)
$(cmake-utils_use_enable python WRAPPER)
$(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
- $(cmake-utils_use test OPENSYNC_UNITTESTS)"
+ $(cmake-utils_use debug OPENSYNC_DEBUG_MODULES)
+ $(cmake-utils_use debug OPENSYNC_TRACE)"
+# $(cmake-utils_use test OPENSYNC_UNITTESTS)"
do_configure() {
if use python; then
@@ -114,6 +113,8 @@ src_install() {
&& python_execute_function -s do_install \
|| do_install
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
if use doc; then
cd "${CMAKE_BUILD_DIR}"
dohtml docs/html/* || die
@@ -121,6 +122,6 @@ src_install() {
}
pkg_postinst() {
- einfo "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
- einfo "the older app-pda/msynctool."
+ elog "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
+ elog "the older app-pda/msynctool."
}