summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/texmacs/texmacs-1.0.7.5.ebuild')
-rw-r--r--app-office/texmacs/texmacs-1.0.7.5.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-office/texmacs/texmacs-1.0.7.5.ebuild b/app-office/texmacs/texmacs-1.0.7.5.ebuild
new file mode 100644
index 000000000000..8f111e8281af
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.5.ebuild,v 1.1 2010/07/28 06:50:30 grozin Exp $
+EAPI=2
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_prepare() {
+ # don't strip
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}