summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice/koffice-1.3_beta4.ebuild')
-rw-r--r--app-office/koffice/koffice-1.3_beta4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/koffice/koffice-1.3_beta4.ebuild b/app-office/koffice/koffice-1.3_beta4.ebuild
new file mode 100644
index 000000000000..20b487da8abc
--- /dev/null
+++ b/app-office/koffice/koffice-1.3_beta4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3_beta4.ebuild,v 1.1 2003/09/25 16:07:31 caleb Exp $
+inherit kde-base flag-o-matic
+
+# TODO : mysql support
+# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
+
+filter-flags "-fomit-frame-pointer"
+
+need-kde 3
+
+MY_P=${PN}-1.2.93
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/unstable/${MY_P}/src/${MY_P}.tar.bz2"
+
+S="$WORKDIR/${MY_P}"
+
+KEYWORDS="~x86"
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5
+ >=app-text/wv2-0.1.8
+ dev-util/pkgconfig"
+
+export LIBPYTHON="`python-config --libs`"
+export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+
+need-automake 1.5
+need-autoconf 2.5
+