summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog8
-rw-r--r--app-misc/mc/files/digest-mc-4.6.01
-rw-r--r--app-misc/mc/mc-4.6.0.ebuild72
3 files changed, 80 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index e38d69c1477a..9c645c84e6ea 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/mc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.5 2003/01/22 20:14:08 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.6 2003/02/06 05:55:15 bcowan Exp $
+
+*mc-4.6.0 (05 Feb 2003)
+
+ 05 Feb 2003; Brad Cowan <bcowan@gentoo.org> mc-4.6.0.ebuild,
+ files/digest-mc-4.6.0:
+ Release version after a year and a half yea :).
*mc-4.6.0_pre3 (22 Jan 2003)
diff --git a/app-misc/mc/files/digest-mc-4.6.0 b/app-misc/mc/files/digest-mc-4.6.0
new file mode 100644
index 000000000000..1ea08f5eaef9
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.0
@@ -0,0 +1 @@
+MD5 70804dc9e2049e24f294ff7090a82a12 mc-4.6.0.tar.gz 3727676
diff --git a/app-misc/mc/mc-4.6.0.ebuild b/app-misc/mc/mc-4.6.0.ebuild
new file mode 100644
index 000000000000..5dc0653f9b06
--- /dev/null
+++ b/app-misc/mc/mc-4.6.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0.ebuild,v 1.1 2003/02/06 05:55:15 bcowan Exp $
+
+IUSE="gpm nls samba ncurses X slang"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ >=sys-libs/pam-0.72
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_compile() {
+ local myconf=""
+
+ if ! use slang && ! use ncurses
+ then
+ myconf="${myconf} --with-screen=mcslang"
+ elif
+ use ncurses && ! use slang
+ then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse" \
+ || myconf="${myconf} --without-gpm-mouse"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba
+ --with-codepagedir=/var/lib/samba/codepages" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-gnu-ld \
+ --with-ext2undel \
+ --with-edit \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall
+
+ dodoc ABOUT-NLS COPYING* ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+}
+