summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/Manifest3
-rw-r--r--app-misc/digitemp/digitemp-3.2.0.ebuild62
-rw-r--r--app-misc/digitemp/files/digest-digitemp-3.2.01
3 files changed, 65 insertions, 1 deletions
diff --git a/app-misc/digitemp/Manifest b/app-misc/digitemp/Manifest
index 6f53ef0b99d1..bd28a2e217b9 100644
--- a/app-misc/digitemp/Manifest
+++ b/app-misc/digitemp/Manifest
@@ -1,2 +1,3 @@
-MD5 7a82710921ac8909bc164269068c85af digitemp-3.2.0.ebuild 1777
+MD5 f22d3621b482028ae32fc07c2535459d digitemp-3.2.0.ebuild 1876
+MD5 1fc48011fb1db95114e5d008646881df ChangeLog 726
MD5 be3c44f8d662d55090d70813c9b3adc9 files/digest-digitemp-3.2.0 66
diff --git a/app-misc/digitemp/digitemp-3.2.0.ebuild b/app-misc/digitemp/digitemp-3.2.0.ebuild
new file mode 100644
index 000000000000..3b4b6aae8db6
--- /dev/null
+++ b/app-misc/digitemp/digitemp-3.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/digitemp/digitemp-3.2.0.ebuild,v 1.1 2003/09/15 14:06:56 seemant Exp $
+
+IUSE="perl python"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Temperature logging and reporting using Dallas Semiconductor's iButtons and 1-Wire protocol"
+HOMEPAGE="http://www.digitemp.com http://www.ibutton.com"
+SRC_URI="http://www.digitemp.com/software/linux/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ # default is to compile to the ds9097u. local use flag takes care of
+ # passive ds9097. the ds9097u setting is what i have, so probably a safe
+ # default - nothing special here.
+ local target="ds9097u"
+ [ "${SERIAL_DRIVER}" = ds9097 ] && target="ds9097"
+ make clean
+
+ ewarn ""
+ ewarn "making for ${target} serial controller. if you would like support"
+ ewarn "for another controller, please set SERIAL_DRIVER=\"ds9097u\" or"
+ ewarn "SERIAL_DRIVER=\"ds9097\" as appropriate"
+ ewarn ""
+
+ make ${target}
+}
+
+src_install() {
+ dobin digitemp
+ dodoc README COPYING FAQ TODO
+
+ # method one: don't treat the examples as docs; place them somewhere else.
+ # then tell the user where to find this stuff. suitable alternative:
+ # specify exampledir="/usr/share/doc/${PF}"
+
+ local exampledir="/usr/share/${PN}"
+ local perldir="${exampledir}/perl_examples"
+ insinto ${perldir}
+ doins perl/*
+ local pythondir="${exampledir}/python_examples"
+ insinto ${pythondir}
+ doins python/*
+ local rrdbdir="${exampledir}/rrdb_examples"
+ insinto ${rrdbdir}
+ doins rrdb/*
+}
+
+pkg_postinst() {
+ ewarn "set the SERIAL_DRIVER environment variable to ds9097 to build"
+ ewarn "for that controller instead"
+ einfo ""
+ einfo "examples of using digitemp with python, perl, and rrdtool are"
+ einfo "located in ${exampledir}"
+ einfo ""
+}
diff --git a/app-misc/digitemp/files/digest-digitemp-3.2.0 b/app-misc/digitemp/files/digest-digitemp-3.2.0
new file mode 100644
index 000000000000..4e90baf8ea48
--- /dev/null
+++ b/app-misc/digitemp/files/digest-digitemp-3.2.0
@@ -0,0 +1 @@
+MD5 6fe9b2c071b733755e9ff8ad4df45ead digitemp-3.2.0.tar.gz 163765