summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/epsxe/ChangeLog7
-rw-r--r--app-emulation/epsxe/files/epsxe9
-rw-r--r--app-emulation/pcsx/ChangeLog5
-rw-r--r--app-emulation/pcsx/files/pcsx20
4 files changed, 25 insertions, 16 deletions
diff --git a/app-emulation/epsxe/ChangeLog b/app-emulation/epsxe/ChangeLog
index 3d483a6aaa6b..158049e34630 100644
--- a/app-emulation/epsxe/ChangeLog
+++ b/app-emulation/epsxe/ChangeLog
@@ -1,8 +1,11 @@
# ChangeLog for app-emulation/epsxe
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/ChangeLog,v 1.6 2003/02/12 04:00:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/epsxe/ChangeLog,v 1.7 2003/04/07 06:22:01 yakina Exp $
-*epsxe-1.5.2 (27 Jul 2002)
+*epsxe-1.5.2 (27 Jul 2002)
+
+ 07 Apr 2003; YAMAKURA Makoto <yakina@gentoo.org> files/epsxe:
+ get rid of a possibility of copyright infringement
17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> epsxe-1.5.2.ebuild :
Added IUSE.
diff --git a/app-emulation/epsxe/files/epsxe b/app-emulation/epsxe/files/epsxe
index 4eecfa960da6..5f1be2edf5b2 100644
--- a/app-emulation/epsxe/files/epsxe
+++ b/app-emulation/epsxe/files/epsxe
@@ -16,9 +16,12 @@ if [ ! -d ~/.epsxe ]; then
if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
ln -s /usr/lib/psemu/bios/scph1001.bin .
else
- wget http://aral3uz.tripod.com/sc.zip
- unzip -L sc.zip
- rm -f sc.zip
+ echo -e "\007"
+ echo "*** Put your BIOS file into $HOME/.epsxe/bios,"
+ echo " or ePSXe may not work!"
+ echo ""
+ echo " Hit enter key to continue..."
+ read
fi
fi
diff --git a/app-emulation/pcsx/ChangeLog b/app-emulation/pcsx/ChangeLog
index 2ae4ddba5f75..46d24e730fb8 100644
--- a/app-emulation/pcsx/ChangeLog
+++ b/app-emulation/pcsx/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/pcsx
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/ChangeLog,v 1.7 2003/02/12 04:01:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/pcsx/ChangeLog,v 1.8 2003/04/07 06:21:37 yakina Exp $
*pcsx-1.4 (11 Dec 2002)
+ 07 Apr 2003; YAMAKURA Makoto <yakina@gentoo.org> files/pcsx:
+ get rid of a possibility of copyright infringement
+
11 Dec 2002; Ryan Phillips <rphillips@gentoo.org> pcsx-1.4.ebuild :
New version
diff --git a/app-emulation/pcsx/files/pcsx b/app-emulation/pcsx/files/pcsx
index b90d0636c953..669879cc2392 100644
--- a/app-emulation/pcsx/files/pcsx
+++ b/app-emulation/pcsx/files/pcsx
@@ -11,8 +11,16 @@ if [ ! -f ~/.pcsx/config ]; then
ln -s /usr/bin/pcsx.bin pcsx
ln -s /usr/lib/psemu/plugins/* plugins/
+ cd bios
+ if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
+ ln -s /usr/lib/psemu/bios/scph1001.bin .
+ biosname=scph1001.bin
+ else
+ biosname=HLE
+ fi
+
cat >$HOME/.pcsx/config <<EOF
-Bios = scph1001.bin
+Bios = $biosname
Gpu = $(basename $(echo plugins/libgpu* | cut -f1 -d\ ) )
Spu = $(basename $(echo plugins/libspu* | cut -f1 -d\ ) )
Cdr = $(basename $(echo plugins/libcdr* | cut -f1 -d\ ) )
@@ -33,15 +41,7 @@ PsxOut = 0
SpuIrq = 0
CdTiming = 0
EOF
-
- cd bios
- if [ -f /usr/lib/psemu/bios/scph1001.bin ]; then
- ln -s /usr/lib/psemu/bios/scph1001.bin .
- else
- wget http://aral3uz.tripod.com/sc.zip
- unzip -L sc.zip
- rm -f sc.zip
- fi
+ unset biosname
fi
cd $HOME/.pcsx/