summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-0.9.15.ebuild')
-rw-r--r--app-emulation/wine/wine-0.9.15.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/app-emulation/wine/wine-0.9.15.ebuild b/app-emulation/wine/wine-0.9.15.ebuild
index 0046377c3fa6..56e973672f46 100644
--- a/app-emulation/wine/wine-0.9.15.ebuild
+++ b/app-emulation/wine/wine-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.3 2006/06/10 22:52:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.4 2006/06/11 01:30:15 eradicator Exp $
inherit eutils flag-o-matic multilib
@@ -60,9 +60,6 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
-# this will not build as 64bit code
-export ABI=x86
-
src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
@@ -105,6 +102,18 @@ src_compile() {
strip-flags
+ if use amd64 ; then
+ # Note, we only need this block if we don't --enable-win64.
+ # If we do --enable-win64, then ./configure takes care of
+ # the toolchain for us.
+ export CHOST="i686-pc-linux-gnu"
+ export CBUILD="${CHOST}"
+
+ # This should be handled by eselect-binutils in the future:
+ export LD="$(tc-getLD) -m elf_i386"
+ export AS="$(tc-getAS) --32"
+ fi
+
# $(use_enable amd64 win64)
econf \
CC="$(tc-getCC)" \