summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/gngb/gngb-20020111.ebuild')
-rw-r--r--app-emulation/gngb/gngb-20020111.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/app-emulation/gngb/gngb-20020111.ebuild b/app-emulation/gngb/gngb-20020111.ebuild
index 0a74c127191b..972be3c6e2c3 100644
--- a/app-emulation/gngb/gngb-20020111.ebuild
+++ b/app-emulation/gngb/gngb-20020111.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gngb/gngb-20020111.ebuild,v 1.8 2002/11/17 22:48:28 hanno Exp $
-
-IUSE="opengl"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gngb/gngb-20020111.ebuild,v 1.9 2002/11/30 02:51:53 vapier Exp $
DESCRIPTION="gngb - Gameboy / Gameboy Color emulator"
HOMEPAGE="http://membres.lycos.fr/frogus/gngb/"
+SRC_URI="http://membres.lycos.fr/frogus/gngb/download/${P}.tar.gz"
+
LICENSE="GPL-2"
KEYWORDS="x86 -ppc"
SLOT="0"
+IUSE="opengl"
+
RDEPEND="media-libs/libsdl
opengl? ( virtual/opengl )"
DEPEND="${RDEPEND}"
-SRC_URI="http://membres.lycos.fr/frogus/gngb/download/${P}.tar.gz"
-S=${WORKDIR}/${P}
src_compile() {
use opengl || myconf=" --with-gl "
-
- econf ${myconf} || die
-
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
dodoc NEWS README TODO INSTALL AUTHORS
make DESTDIR=${D} install || die
}