summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/haskell-mode/haskell-mode-1.45.ebuild')
-rw-r--r--app-emacs/haskell-mode/haskell-mode-1.45.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/haskell-mode/haskell-mode-1.45.ebuild b/app-emacs/haskell-mode/haskell-mode-1.45.ebuild
new file mode 100644
index 000000000000..9bde5bbdcb7b
--- /dev/null
+++ b/app-emacs/haskell-mode/haskell-mode-1.45.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/haskell-mode/haskell-mode-1.45.ebuild,v 1.1 2005/02/20 11:07:38 usata Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Mode for editing (and running) Haskell programs in Emacs"
+HOMEPAGE="http://www.haskell.org/haskell-mode/"
+SRC_URI="http://www.haskell.org/haskell-mode/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp_src_install
+ dohtml *.html *.hs
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ einfo "See /usr/share/doc/${P}/html/installation-guide.html"
+}