summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/wxhexeditor/ChangeLog11
-rw-r--r--app-editors/wxhexeditor/Manifest15
-rw-r--r--app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch37
-rw-r--r--app-editors/wxhexeditor/metadata.xml8
-rw-r--r--app-editors/wxhexeditor/wxhexeditor-0.09.ebuild32
5 files changed, 103 insertions, 0 deletions
diff --git a/app-editors/wxhexeditor/ChangeLog b/app-editors/wxhexeditor/ChangeLog
new file mode 100644
index 000000000000..9010cb22ccdb
--- /dev/null
+++ b/app-editors/wxhexeditor/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-editors/wxhexeditor
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/ChangeLog,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+
+*wxhexeditor-0.09 (31 Aug 2010)
+
+ 31 Aug 2010; Ryan Hill <dirtyepic@gentoo.org> +wxhexeditor-0.09.ebuild,
+ +files/wxhexeditor-0.09-gcc45.patch, +metadata.xml:
+ Initial import. Based on ebuilds by Yoshi Watanabe and Philipp Richter in
+ bug #283994.
+
diff --git a/app-editors/wxhexeditor/Manifest b/app-editors/wxhexeditor/Manifest
new file mode 100644
index 000000000000..953e562d6c3c
--- /dev/null
+++ b/app-editors/wxhexeditor/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX wxhexeditor-0.09-gcc45.patch 1463 RMD160 4e770ddde0c13d8e01545a7a534fdfd7fefbc4f3 SHA1 ffafb87a0dbc7964b08216f6eaf20be91c1a4487 SHA256 8ade73245bec12590606533cd5a430fa2b444dae02e5d993d48227b3039972a6
+DIST wxHexEditor-v0.09-src.tar.bz2 419074 RMD160 589337f706363386119e71f7f8986c97ee57f522 SHA1 feaee5766219bc4b34fef60c5cdeb4ebb585ef33 SHA256 2d2b0cc257f1f5eccc4031422863de91d1eec2b15d031041878646835e1f8cc7
+EBUILD wxhexeditor-0.09.ebuild 741 RMD160 c3ff8d06144190713788d9f861e4df2a7dc5226c SHA1 c64d9c313a83f0de1bca49953923d89a6a16dbd0 SHA256 90b65540f0b5017a7b1d0e200ee551045b695167785bfe733ea678a0fe05cdac
+MISC ChangeLog 475 RMD160 8eda413d8fd68e9cf2f3851cbf234d5107c8a5e0 SHA1 0b7f85e06a5c8c7f2a3c050278ce68c8ac3bc561 SHA256 d63363f931b5769d5a46d9d9b5670804b52dc30e1253edaa6d810d67f1b7c643
+MISC metadata.xml 230 RMD160 0508220ff99c080f905c3c05272047d1e36e0f1f SHA1 0481ec39da10930aa576f61d45041c3b189697c8 SHA256 59b9beec10bb60f8533f070be1dfeef7834a2865f0e905f9afa7edb8e164de9b
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkx8gz0ACgkQiqiDRvmkBmJXxACdG2H2axBhOW/bOM3x7HPF+nYM
+g3UAoJyYP2Fa8pm0QbUxWfEV7xya3rX2
+=N9P0
+-----END PGP SIGNATURE-----
diff --git a/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch b/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
new file mode 100644
index 000000000000..c49e8a2452ca
--- /dev/null
+++ b/app-editors/wxhexeditor/files/wxhexeditor-0.09-gcc45.patch
@@ -0,0 +1,37 @@
+http://wxhexeditor.svn.sourceforge.net/viewvc/wxhexeditor/trunk/src/HexEditor.cpp?r1=132&r2=145
+
+--- a/src/HexEditor.cpp
++++ b/src/HexEditor.cpp
+@@ -102,7 +102,7 @@ bool HexEditor::FileOpen(wxFileName& myfilename ){
+ wxLogError(_("Critical Error. File pointer is not empty!"));
+ return false;
+ }
+- else if(myfilename.IsFileReadable()){ //IsFileReadable
++ else if( myfilename.IsFileReadable() ){ //IsFileReadable
+ if ( myfilename.GetSize( ) < 50*MB && myfilename.IsFileWritable() )
+ myfile = new FileDifference( myfilename, FileDifference::ReadWrite );
+ else
+@@ -869,20 +869,20 @@ void HexEditor::OnMouseTest( wxMouseEvent& event ){
+ }
+
+ void HexEditor::FindDialog( void ){
+- class FindDialog *myfind = new FindDialog::FindDialog( this, myfile );
++ ::FindDialog *myfind = new ::FindDialog( this, myfile );
+ myfind->ShowModal();
+ myfind->Destroy();
+ }
+
+ void HexEditor::ReplaceDialog( void ){
+- class ReplaceDialog *myfind = new ReplaceDialog::ReplaceDialog( this, myfile );
++ ::ReplaceDialog *myfind = new ::ReplaceDialog( this, myfile );
+ myfind->ShowModal();
+ myfind->Destroy();
+ }
+
+ void HexEditor::GotoDialog( void ){
+ uint64_t newoffset;
+- class GotoDialog *mygoto = new GotoDialog::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
++ ::GotoDialog *mygoto = new ::GotoDialog( this, newoffset, CursorOffset(), FileLength(), myDialogVector );
+ if( mygoto->ShowModal() == wxID_OK ){
+ Goto( newoffset );
+ }
diff --git a/app-editors/wxhexeditor/metadata.xml b/app-editors/wxhexeditor/metadata.xml
new file mode 100644
index 000000000000..1d5f99d169fe
--- /dev/null
+++ b/app-editors/wxhexeditor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>wxwidgets</herd>
+ <maintainer>
+ <email>wxwidgets@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild b/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild
new file mode 100644
index 000000000000..1cbe530d35a4
--- /dev/null
+++ b/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/wxhexeditor/wxhexeditor-0.09.ebuild,v 1.1 2010/08/31 04:16:58 dirtyepic Exp $
+
+EAPI=3
+WX_GTK_VER=2.8
+
+inherit eutils wxwidgets
+
+MY_PN="wxHexEditor"
+
+DESCRIPTION="A cross-platform hex editor designed specially for large files."
+HOMEPAGE="http://wxhexeditor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-v${PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}