summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/mhash/mhash-0.9.9.9.ebuild')
-rw-r--r--app-crypt/mhash/mhash-0.9.9.9.ebuild44
1 files changed, 19 insertions, 25 deletions
diff --git a/app-crypt/mhash/mhash-0.9.9.9.ebuild b/app-crypt/mhash/mhash-0.9.9.9.ebuild
index 2aea6095b18f..f453c2196cf8 100644
--- a/app-crypt/mhash/mhash-0.9.9.9.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.9.9.ebuild,v 1.2 2010/04/01 08:42:53 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.9.9.ebuild,v 1.3 2011/07/29 06:23:45 ssuominen Exp $
+EAPI=4
inherit eutils
DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
@@ -11,37 +12,30 @@ SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE=""
+IUSE="static-libs"
-DEPEND=""
RDEPEND=""
+DEPEND="dev-lang/perl" # pod2html
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix for issues in bug #181563
- #epatch "${FILESDIR}/${PN}-0.9.9-mutils-align.patch"
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.9-fix-{mem-leak,snefru-segfault,whirlpool-segfault}.patch \
+ "${FILESDIR}"/${PN}-0.9.9-autotools-namespace-stomping.patch
+}
- epatch "${FILESDIR}"/${PN}-0.9.9-fix-mem-leak.patch
- epatch "${FILESDIR}"/${PN}-0.9.9-fix-snefru-segfault.patch
- epatch "${FILESDIR}"/${PN}-0.9.9-fix-whirlpool-segfault.patch
- epatch "${FILESDIR}"/${PN}-0.9.9-autotools-namespace-stomping.patch
+src_configure() {
+ econf $(use_enable static-libs static)
}
src_compile() {
- econf \
- --enable-static \
- --enable-shared || die
- emake || die "make failure"
- cd doc && emake mhash.html || die "failed to build html"
+ default
+ emake -C doc mhash.html
}
src_install() {
- dodir /usr/{bin,include,lib}
- make install DESTDIR="${D}" || die "install failure"
-
- dodoc AUTHORS INSTALL NEWS README TODO THANKS ChangeLog
- dodoc doc/skid* doc/*.c
- dohtml doc/mhash.html || die "dohtml failed"
+ emake DESTDIR="${D}" install
+ use static-libs || rm -f "${ED}"usr/lib*/libmhash.la
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO \
+ doc/{example.c,skid2-authentication}
+ dohtml doc/mhash.html
}