summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/xfburn/xfburn-0.3.2.ebuild')
-rw-r--r--app-cdr/xfburn/xfburn-0.3.2.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/app-cdr/xfburn/xfburn-0.3.2.ebuild b/app-cdr/xfburn/xfburn-0.3.2.ebuild
deleted file mode 100644
index 83c3d60f0c2e..000000000000
--- a/app-cdr/xfburn/xfburn-0.3.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xfburn/xfburn-0.3.2.ebuild,v 1.4 2008/10/25 16:05:28 nixnut Exp $
-
-EAPI=1
-
-inherit eutils gnome2-utils
-
-DESCRIPTION="GTK+ based CD and DVD burning application"
-HOMEPAGE="http://www.xfce.org/projects/xfburn"
-SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="+dbus debug hal +xfce"
-
-RDEPEND=">=dev-libs/libburn-0.3
- >=dev-libs/libisofs-0.6.2
- >=x11-libs/gtk+-2.10
- >=xfce-base/libxfcegui4-4.4
- >=xfce-extra/exo-0.3
- xfce? ( xfce-base/thunar )
- dbus? ( dev-libs/dbus-glib )
- hal? ( sys-apps/hal )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- dev-util/intltool
- sys-devel/gettext"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-disable-hal.patch
-}
-
-src_compile() {
- econf --disable-dependency-tracking \
- $(use_enable xfce thunar-vfs) \
- $(use_enable dbus) \
- $(use_enable hal) \
- $(use_enable debug)
- emake || die "emake failed."
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}