summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/flac/files/digest-flac-1.0.21
-rw-r--r--media-libs/flac/flac-1.0.2.ebuild33
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild59
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-0.5.12a1
-rw-r--r--sys-apps/mosix-user/files/mosix.init11
-rw-r--r--x11-terms/aterm/aterm-0.4.2.ebuild6
6 files changed, 101 insertions, 10 deletions
diff --git a/media-libs/flac/files/digest-flac-1.0.2 b/media-libs/flac/files/digest-flac-1.0.2
new file mode 100644
index 000000000000..8303c3a12b57
--- /dev/null
+++ b/media-libs/flac/files/digest-flac-1.0.2
@@ -0,0 +1 @@
+MD5 3b0c646f1e58d5345f3c555c3996885d flac-1.0.2-src.tar.gz 462848
diff --git a/media-libs/flac/flac-1.0.2.ebuild b/media-libs/flac/flac-1.0.2.ebuild
new file mode 100644
index 000000000000..bc646a7da19c
--- /dev/null
+++ b/media-libs/flac/flac-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.0.2.ebuild,v 1.1 2001/12/12 05:29:04 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A free lossless audio encoder"
+SRC_URI="http://prdownloads.sourceforge.net/flac/${P}-src.tar.gz"
+HOMEPAGE="http://flac.sourceforge.net/"
+#flac has an optional xmms plugin. For now, we just depend on xmms. We can optimize this later.
+RDEPEND="virtual/glibc X? ( >=media-sound/xmms-1.2.5-r2 ) >=media-libs/libogg-1.0_rc2"
+DEPEND="virtual/glibc dev-lang/nasm sys-apps/gawk $RDEPEND"
+
+src_compile() {
+ cd ${S}
+ local myflags
+ [ `use sse` ] && myflags="--sse-os"
+ #--use-3dnow is documented but apparently not yet enabled.
+ #[ `use 3dnow` ] && myflags="$myflags --use-3dnow"
+ ./configure --prefix=/usr $myflags --host=$CHOST || die
+ cp Makefile Makefile.orig
+ #the man page ebuild requires docbook2man... yick!
+ sed -e 's:include man:include:g' Makefile.orig > Makefile
+ #emake seems to mess up the building of the xmms input plugin
+ make || die
+}
+src_install() {
+ #it looks like we need to run the xmms install first
+ ( cd src/plugin_xmms; make DESTDIR=${D} install )
+ make DESTDIR=${D} install
+}
+
+
diff --git a/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild b/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild
new file mode 100644
index 000000000000..869d12e4757a
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.5.12a.ebuild,v 1.1 2001/12/12 05:29:04 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Advanced Linux Sound Architecture modules"
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/alsa-driver-${PV}.tar.bz2"
+HOMEPAGE="http://www.alsa-project.org"
+
+#virtual/glibc should depend on specific kernel headers
+DEPEND="sys-devel/autoconf virtual/glibc"
+PROVIDE="virtual/alsa"
+
+#might be good to roll this into Portage at some point.
+KV=`readlink /usr/src/linux`
+if [ $? -ne 0 ]
+then
+ echo
+ echo "/usr/src/linux symlink does not exist; cannot continue."
+ echo
+ exit 1
+fi
+#alsa-driver will compile modules for the kernel pointed to by /usr/src/linux
+KV=${KV/linux-/}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure.in configure.in.orig
+ sed -e 's/-m.86//g' configure.in.orig > configure.in
+ autoconf
+}
+
+src_compile() {
+ try ./configure --with-kernel="${ROOT}usr/src/linux-${KV}" --with-isapnp=yes --with-sequencer=yes --with-oss=yes --with-cards=all
+ try emake
+}
+
+src_install () {
+ #point this to the kernel headers in the future, not the kernel sources
+ insinto /usr/include/linux
+ cd ${S}/include
+ doins asound.h asoundid.h asequencer.h ainstr_*.h
+ dodoc INSTALL FAQ
+ dodir /lib/modules/${KV}/misc
+ cp ${S}/modules/*.o ${D}/lib/modules/${KV}/misc
+ dodir /etc/modutils
+ insinto /etc/modutils
+ doins ${FILESDIR}/alsa
+ #this is the new modular modules system (from Debian) :)
+}
+
+pkg_postinst() {
+ if [ -e /sbin/update-modules ]
+ then
+ /sbin/update-modules
+ fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-0.5.12a b/media-sound/alsa-driver/files/digest-alsa-driver-0.5.12a
new file mode 100644
index 000000000000..b461bf83c87a
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-0.5.12a
@@ -0,0 +1 @@
+MD5 2c6ace1dd097f03514ca270e9879ee44 alsa-driver-0.5.12a.tar.bz2 917504
diff --git a/sys-apps/mosix-user/files/mosix.init b/sys-apps/mosix-user/files/mosix.init
index b52330a3fb2c..97aadd2c118d 100644
--- a/sys-apps/mosix-user/files/mosix.init
+++ b/sys-apps/mosix-user/files/mosix.init
@@ -1,4 +1,4 @@
-#!/bin/runscript
+#!/sbin/runscript
depend() {
need net
@@ -13,17 +13,16 @@ stop() {
start() {
ebegin "Starting MOSIX"
- #do some first-time setup if MOSIX isn't configured
- [ ! -f /etc/mosix.map ] && firstsetup
-
if [ -s /etc/overheads -a -f /proc/mosix/admin/overheads ]
then
- /bin/grep -v '^#' /etc/overheads > /proc/mosix/admin/overheads
+ grep -v '^#' /etc/overheads > /proc/mosix/admin/overheads
fi
if [ -s /etc/mfscosts -a -f /proc/mosix/admin/mfscosts ]
then
- /bin/grep -v '^#' /etc/mfscosts > /proc/mosix/admin/mfscosts
+ grep -v '^#' /etc/mfscosts > /proc/mosix/admin/mfscosts
fi
+ local a1
+ local a2
a1=
[ -s /etc/mospe ] && a1="-p `cat /etc/mospe`"
a2=
diff --git a/x11-terms/aterm/aterm-0.4.2.ebuild b/x11-terms/aterm/aterm-0.4.2.ebuild
index 7507ba4c4e11..505e25da7c8e 100644
--- a/x11-terms/aterm/aterm-0.4.2.ebuild
+++ b/x11-terms/aterm/aterm-0.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Aaron Blew <moath@oddbox.org>
# /home/cvsroot/gentoo-x86/x11-terms/aterm/,v 1.2 2001/02/15 18:17:31 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/aterm-0.4.2.ebuild,v 1.4 2001/12/11 20:46:20 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/aterm/aterm-0.4.2.ebuild,v 1.5 2001/12/12 05:29:04 drobbins Exp $
S=${WORKDIR}/${P}
@@ -10,9 +10,7 @@ DESCRIPTION="A terminal emulator with transparency support as well as rxvt backw
SRC_URI="http://prdownloads.sf.net/aterm/${P}.tar.gz"
HOMEPAGE="http://aterm.sourceforge.net"
-DEPEND=">=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.0.11
- virtual/x11"
+DEPEND=">=media-libs/jpeg-6b-r2 >=media-libs/libpng-1.0.11 virtual/x11"
src_compile() {