summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/opencv/ChangeLog10
-rw-r--r--media-libs/opencv/Manifest4
-rw-r--r--media-libs/opencv/metadata.xml11
-rw-r--r--media-libs/opencv/opencv-1.0.0.ebuild60
4 files changed, 85 insertions, 0 deletions
diff --git a/media-libs/opencv/ChangeLog b/media-libs/opencv/ChangeLog
new file mode 100644
index 000000000000..453bd362cd34
--- /dev/null
+++ b/media-libs/opencv/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/opencv
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/ChangeLog,v 1.1 2008/06/18 05:24:34 jmglov Exp $
+
+*opencv-1.0.0 (18 Jun 2008)
+
+ 18 Jun 2008; Josh Glover <jmglov@gentoo.org> +metadata.xml,
+ +opencv-1.0.0.ebuild:
+ Added to Portage tree
+
diff --git a/media-libs/opencv/Manifest b/media-libs/opencv/Manifest
new file mode 100644
index 000000000000..bed7c01eb41c
--- /dev/null
+++ b/media-libs/opencv/Manifest
@@ -0,0 +1,4 @@
+DIST opencv-1.0.0.tar.gz 11146334 RMD160 f041798ea63101b90e945957e0d0ad3f7497dcd4 SHA1 c7dd500703b0060cedfa049fcb33de0846e631fb SHA256 3a6ee888e4dd4ab7f2bc80d046688c099c6a95d1267af554b7c8f1543b66f21e
+EBUILD opencv-1.0.0.ebuild 1786 RMD160 61244a24467c378f1b1c15e8461d138712c83460 SHA1 926c9f67cad47f7f9cca25c305b2c13590323f87 SHA256 978dcd68d829d6f3b7ba9952f78b6ededc3f5c87ad7b4f5471a6cba2d0250ccc
+MISC ChangeLog 347 RMD160 2b9b65eb0ff3cd089e4d018325bfcaaa1bc4c529 SHA1 421d6ac8fe20bf0da521ee19a660af12d371969f SHA256 c88b234f43e3a3690194f710a151aa758b8c2c8f73845df01f5509e8e88a75f1
+MISC metadata.xml 652 RMD160 5cfb86ff65264086bc032c406763d3cc46b075d2 SHA1 771ee2dc24641518bbacc47bbffa356d0c071a35 SHA256 b63ce92a359d882b519ef92ef358a73ce854bd875e19c283c72217b0d7965bdc
diff --git a/media-libs/opencv/metadata.xml b/media-libs/opencv/metadata.xml
new file mode 100644
index 000000000000..085de321c6b3
--- /dev/null
+++ b/media-libs/opencv/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>jmglov@gentoo.org</email>
+<name>Josh Glover</name>
+</maintainer>
+<longdescription>OpenCV (Open Source Computer Vision) is a library of programming functions mainly aimed at real time computer vision.
+
+Example applications of the OpenCV library are Human-Computer Interaction (HCI); Object Identification, Segmentation and Recognition; Face Recognition; Gesture Recognition; Motion Tracking, Ego Motion, Motion Understanding; Structure From Motion (SFM); and Mobile Robotics.</longdescription>
+</pkgmetadata>
diff --git a/media-libs/opencv/opencv-1.0.0.ebuild b/media-libs/opencv/opencv-1.0.0.ebuild
new file mode 100644
index 000000000000..ee0e303c2fe5
--- /dev/null
+++ b/media-libs/opencv/opencv-1.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/opencv/opencv-1.0.0.ebuild,v 1.1 2008/06/18 05:24:34 jmglov Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenCV is a library of programming functions mainly aimed at real time computer vision."
+HOMEPAGE="http://opencvlibrary.sourceforge.net/"
+SRC_URI="mirror://sourceforge/opencvlibrary/${P}.tar.gz"
+
+LICENSE="Intel"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ffmpeg gtk ieee1394 python swig v4l v4l2 xine"
+
+DEPEND="
+ dev-util/pkgconfig
+ media-libs/jasper
+ media-libs/jpeg
+ media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9 )
+ ieee1394? ( media-libs/libdc1394 )
+ ieee1394? ( sys-libs/libraw1394 )
+ gtk? ( >=x11-libs/gtk+-2 )
+ python? ( >=dev-lang/python-2.3 )
+ swig? ( dev-lang/swig )
+ xine? ( media-libs/xine-lib )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf="--without-quicktime"
+
+ if use ffmpeg ; then
+ ## TODO: jmglov 2008/06/18
+ ## Remove this junk once bug # 227975 is resolved
+ ewarn "${PN} currently will not build with ffmpeg support"
+ ewarn "Please enable the 'xine' USE flag instead"
+ ewarn "Working on this in bug # 227975"
+ die "configuration failed; see above"
+ ## TODO: jmglov 2008/06/18
+
+ myconf="${myconf} --with-ffmpeg --without-xine"
+ elif use xine ; then
+ myconf="${myconf} --with-xine --without-ffmpeg"
+ else
+ die "You must set one of the 'ffmpeg' or 'xine' USE flags"
+ fi
+
+ myconf="${myconf} $(use_with ieee1394 1394libs)"
+ myconf="${myconf} $(use_with python)"
+ myconf="${myconf} $(use_with swig)"
+ myconf="${myconf} $(use_with v4l)"
+
+ econf ${myconf} || die "econf failed"
+
+ emake || die "emake failed"
+}