summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-officeext/texmaths/ChangeLog10
-rw-r--r--app-officeext/texmaths/metadata.xml5
-rw-r--r--app-officeext/texmaths/texmaths-0.34.ebuild34
3 files changed, 49 insertions, 0 deletions
diff --git a/app-officeext/texmaths/ChangeLog b/app-officeext/texmaths/ChangeLog
new file mode 100644
index 000000000000..c0dea0010b38
--- /dev/null
+++ b/app-officeext/texmaths/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-officeext/texmaths
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/texmaths/ChangeLog,v 1.1 2012/05/08 21:36:28 dilfridge Exp $
+
+*texmaths-0.34 (08 May 2012)
+
+ 08 May 2012; Andreas K. Huettel <dilfridge@gentoo.org> +texmaths-0.34.ebuild,
+ +metadata.xml:
+ New package
+
diff --git a/app-officeext/texmaths/metadata.xml b/app-officeext/texmaths/metadata.xml
new file mode 100644
index 000000000000..5d46203011d6
--- /dev/null
+++ b/app-officeext/texmaths/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+</pkgmetadata>
diff --git a/app-officeext/texmaths/texmaths-0.34.ebuild b/app-officeext/texmaths/texmaths-0.34.ebuild
new file mode 100644
index 000000000000..636698b53d64
--- /dev/null
+++ b/app-officeext/texmaths/texmaths-0.34.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-officeext/texmaths/texmaths-0.34.ebuild,v 1.1 2012/05/08 21:36:28 dilfridge Exp $
+
+EAPI=4
+
+MY_P="TexMaths-${PV}"
+
+OO_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext
+
+DESCRIPTION="LaTeX Equation Editor for LibreOffice"
+HOMEPAGE="http://roland65.free.fr/texmaths/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.oxt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/dvisvgm
+ virtual/tex-base
+"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp -v "${DISTDIR}/${MY_P}.oxt" "${S}"
+}