summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/ncompress/ncompress-4.2.4.ebuild24
-rw-r--r--app-arch/par/par-1.1.ebuild7
-rw-r--r--app-arch/rar/files/digest-rar-3.0_beta71
-rw-r--r--app-arch/rar/rar-3.0.ebuild10
-rw-r--r--app-arch/rar/rar-3.0_beta7.ebuild36
-rw-r--r--app-arch/rpm2targz/rpm2targz-8.0.ebuild7
-rw-r--r--app-arch/unace/unace-2.0.4.ebuild9
-rw-r--r--app-arch/unarj/unarj-2.63a.ebuild13
-rw-r--r--app-arch/unlzx/unlzx-1.1.ebuild12
-rw-r--r--app-arch/unrar/unrar-2.50.ebuild30
-rw-r--r--app-arch/unrar/unrar-3.00-r1.ebuild10
-rw-r--r--app-arch/unrar/unrar-3.00.ebuild25
-rw-r--r--app-arch/unzip/files/digest-unzip-5.41-r21
-rw-r--r--app-arch/unzip/files/digest-unzip-5.421
-rw-r--r--app-arch/unzip/unzip-5.41-r2.ebuild34
-rw-r--r--app-arch/unzip/unzip-5.42-r1.ebuild33
-rw-r--r--app-arch/unzip/unzip-5.42.ebuild36
17 files changed, 61 insertions, 228 deletions
diff --git a/app-arch/ncompress/ncompress-4.2.4.ebuild b/app-arch/ncompress/ncompress-4.2.4.ebuild
index f43d1ea37449..04d1472cd476 100644
--- a/app-arch/ncompress/ncompress-4.2.4.ebuild
+++ b/app-arch/ncompress/ncompress-4.2.4.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ncompress/ncompress-4.2.4.ebuild,v 1.4 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ncompress/ncompress-4.2.4.ebuild,v 1.5 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Another uncompressor for compatibility"
SRC_URI="ftp://ftp.leo.org/pub/comp/os/unix/linux/sunsite/utils/compress/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.leo.org/pub/comp/os/unix/linux/sunsite/utils/compress/"
+
SLOT="0"
-HOMEPAGE="http://"
+LICENSE="public-domain"
KEYWORDS="x86 ppc"
src_compile() {
-
- cd ${S}
- sed -e "s:options= :options= ${CFLAGS} :" Makefile.def > Makefile
- make || die
-
+ cd ${S}
+ sed -e "s:options= :options= ${CFLAGS} :" Makefile.def > Makefile
+ make || die
}
src_install () {
-
- dobin compress
- dosym compress /usr/bin/uncompress
- doman compress.1
+ dobin compress
+ dosym compress /usr/bin/uncompress
+ doman compress.1
}
-
diff --git a/app-arch/par/par-1.1.ebuild b/app-arch/par/par-1.1.ebuild
index 61b4877de7ab..018ba4862955 100644
--- a/app-arch/par/par-1.1.ebuild
+++ b/app-arch/par/par-1.1.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/par/par-1.1.ebuild,v 1.5 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/par/par-1.1.ebuild,v 1.6 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/par-cmdline
DESCRIPTION="Parchive archive fixing tool"
SRC_URI="mirror://sourceforge/parchive/par-v${PV}.tar.gz"
-SLOT="0"
HOMEPAGE="http://parchive.sourceforge.net"
+
+SLOT="0"
LICENSE="GPL-2"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_unpack() {
diff --git a/app-arch/rar/files/digest-rar-3.0_beta7 b/app-arch/rar/files/digest-rar-3.0_beta7
deleted file mode 100644
index 8a944d80c07a..000000000000
--- a/app-arch/rar/files/digest-rar-3.0_beta7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 cdc10028fc0c20e043219e0d638a919a rarlinux-3.0.b7.tar.gz 503169
diff --git a/app-arch/rar/rar-3.0.ebuild b/app-arch/rar/rar-3.0.ebuild
index 81f7761cb7ee..82e51b20b669 100644
--- a/app-arch/rar/rar-3.0.ebuild
+++ b/app-arch/rar/rar-3.0.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/rar-3.0.ebuild,v 1.4 2002/07/21 01:19:13 cardoe Exp $
-
-LICENSE="RAR"
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/rar-3.0.ebuild,v 1.5 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/${PN}
-
MY_P=${PN}linux-${PV}
-SLOT="0"
DESCRIPTION="RAR compressor/uncompressor"
SRC_URI="http://www.rarlab.com/rar/${MY_P}.tar.gz"
-SLOT="0"
HOMEPAGE="http://www.rarsoft.com"
+
+SLOT="0"
+LICENSE="RAR"
KEYWORDS="x86"
RDEPEND="virtual/glibc"
diff --git a/app-arch/rar/rar-3.0_beta7.ebuild b/app-arch/rar/rar-3.0_beta7.ebuild
deleted file mode 100644
index 8c8df397e236..000000000000
--- a/app-arch/rar/rar-3.0_beta7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rar/rar-3.0_beta7.ebuild,v 1.4 2002/07/21 01:19:13 cardoe Exp $
-
-LICENSE="RAR"
-
-S=${WORKDIR}/rar
-
-DESCRIPTION="RAR compressor/uncompressor"
-SRC_URI="http://www.rarlab.com/rar/rarlinux-${PV/_beta/.b}.tar.gz"
-SLOT="0"
-HOMEPAGE="http://www.rarsoft.com"
-KEYWORDS="x86"
-
-RDEPEND="virtual/glibc"
-
-src_install () {
- dodir /opt/${PN}
- for i in bin etc lib
- do
- dodir /opt/${PN}/${i}
- done
-
- exeinto /opt/${PN}/bin
- doexe rar unrar
- insinto /opt/${PN}/lib
- doins default.sfx
- insinto /opt/${PN}/etc
- doins rarfiles.lst
-
- dodoc *.{txt,diz}
-
- dodir /etc/env.d
- insinto /etc/env.d
- doins ${FILESDIR}/10rar
-}
diff --git a/app-arch/rpm2targz/rpm2targz-8.0.ebuild b/app-arch/rpm2targz/rpm2targz-8.0.ebuild
index fc1bd8b83d59..12608b243659 100644
--- a/app-arch/rpm2targz/rpm2targz-8.0.ebuild
+++ b/app-arch/rpm2targz/rpm2targz-8.0.ebuild
@@ -1,13 +1,16 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm2targz/rpm2targz-8.0.ebuild,v 1.3 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm2targz/rpm2targz-8.0.ebuild,v 1.4 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
SRC_URI="ftp://ftp.slackware.com/pub/slackware/slackware-${PV}/source/a/bin/rpm2targz
ftp://ftp.slackware.com/pub/slackware/slackware-${PV}/source/a/bin/rpmoffset.c
ftp://ftp.slackware.com/pub/slackware/slackware-${PV}/source/a/bin/rpm2targz.README"
+
SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
DEPEND="virtual/glibc"
diff --git a/app-arch/unace/unace-2.0.4.ebuild b/app-arch/unace/unace-2.0.4.ebuild
index 24552a5a30b5..b52dcdfc2251 100644
--- a/app-arch/unace/unace-2.0.4.ebuild
+++ b/app-arch/unace/unace-2.0.4.ebuild
@@ -1,13 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-2.0.4.ebuild,v 1.3 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-2.0.4.ebuild,v 1.4 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}
DESCRIPTION="ACE unarchiver"
SRC_URI="http://www.vikingassociates.com/winace/linunace204.tgz"
-SLOT="0"
HOMEPAGE="http://www.winace.com/"
-LICENSE="Proprietary"
+
+SLOT="0"
+LICENSE="freedist"
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_install () {
diff --git a/app-arch/unarj/unarj-2.63a.ebuild b/app-arch/unarj/unarj-2.63a.ebuild
index 91625ac2a36a..a900f94259ad 100644
--- a/app-arch/unarj/unarj-2.63a.ebuild
+++ b/app-arch/unarj/unarj-2.63a.ebuild
@@ -1,20 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unarj/unarj-2.63a.ebuild,v 1.2 2002/07/19 21:55:16 rphillips Exp $
-
-# Free to use unarj utility. Can be distributed but copyright has to remain
-# intact.
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unarj/unarj-2.63a.ebuild,v 1.3 2002/07/25 14:47:35 seemant Exp $
DESCRIPTION="Utility for opening arj archives."
HOMEPAGE="http://ibiblio.org/pub/Linux/utils/compress/"
-LICENSE="arj"
-DEPEND="virtual/glibc
- >=sys-apps/baselayout-1.8.0"
-RDEPEND="${DEPEND}"
SRC_URI="http://ibiblio.org/pub/Linux/utils/compress/${P}.tar.gz"
+
SLOT="0"
+LICENSE="arj"
KEYWORDS="x86"
+DEPEND=">=sys-apps/baselayout-1.8.0"
+
src_compile () {
emake || die
}
diff --git a/app-arch/unlzx/unlzx-1.1.ebuild b/app-arch/unlzx/unlzx-1.1.ebuild
index f44e6d0d75d7..42254e11cdfd 100644
--- a/app-arch/unlzx/unlzx-1.1.ebuild
+++ b/app-arch/unlzx/unlzx-1.1.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/unlzx-1.1.ebuild,v 1.3 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unlzx/unlzx-1.1.ebuild,v 1.4 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/${P}
-
DESCRIPTION="Unarchiver for Amiga LZX archives"
-
-#This site is listed as the master site in NetBSD makefile
SRC_URI="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
-SLOT="0"
-
-#For lack of anything better
HOMEPAGE="ftp://us.aminet.net/pub/aminet/misc/unix/${PN}.c.gz.readme"
+SLOT="0"
+LICENSE=""
+KEYWORDS="x86"
+
DEPEND="virtual/glibc"
src_unpack() {
diff --git a/app-arch/unrar/unrar-2.50.ebuild b/app-arch/unrar/unrar-2.50.ebuild
deleted file mode 100644
index d3f09871ebac..000000000000
--- a/app-arch/unrar/unrar-2.50.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-2.50.ebuild,v 1.8 2002/07/17 20:44:57 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Uncompress rar files"
-SRC_URI="ftp://ftp.elf.stuba.sk/pub/pc/pack/unrar250.zip"
-SLOT="0"
-HOMEPAGE="ftp://ftp.elf.stuba.sk/pub/pc/pack"
-LICENSE="unRAR"
-
-DEPEND="virtual/glibc app-arch/unzip"
-RDEPEND="virtual/glibc"
-# Might be more depends... probably not, though
-
-src_compile() {
-# Many many warnings... but seems to work okay
- cd src
- mv Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" -e "s:-Wall::" Makefile.orig > Makefile
- try make
-}
-
-src_install() {
- dobin src/unrar
- dodoc readme.txt license.txt
-}
-
-
-
diff --git a/app-arch/unrar/unrar-3.00-r1.ebuild b/app-arch/unrar/unrar-3.00-r1.ebuild
index da5c61c5810a..8ffbd210d619 100644
--- a/app-arch/unrar/unrar-3.00-r1.ebuild
+++ b/app-arch/unrar/unrar-3.00-r1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.00-r1.ebuild,v 1.4 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.00-r1.ebuild,v 1.5 2002/07/25 14:47:35 seemant Exp $
MY_P=${PN}src
S=${WORKDIR}
DESCRIPTION="Uncompress rar files"
SRC_URI="ftp://ftp.elf.stuba.sk/pub/pc/pack/${MY_P}.tgz"
-SLOT="0"
HOMEPAGE="ftp://ftp.elf.stuba.sk/pub/pc/pack"
+
+SLOT="0"
LICENSE="unRAR"
+KEYWORDS="x86"
-DEPEND="virtual/glibc
- app-arch/unzip"
-RDEPEND="virtual/glibc"
+DEPEND="app-arch/unzip"
src_compile() {
cp ${FILESDIR}/unrar-3.00-rartypes.hpp rartypes.hpp
diff --git a/app-arch/unrar/unrar-3.00.ebuild b/app-arch/unrar/unrar-3.00.ebuild
deleted file mode 100644
index 8daf7e062a3b..000000000000
--- a/app-arch/unrar/unrar-3.00.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.00.ebuild,v 1.4 2002/07/17 20:44:57 drobbins Exp $
-
-MY_P=${PN}src
-S=${WORKDIR}
-DESCRIPTION="Uncompress rar files"
-SRC_URI="ftp://ftp.elf.stuba.sk/pub/pc/pack/${MY_P}.tgz"
-SLOT="0"
-HOMEPAGE="ftp://ftp.elf.stuba.sk/pub/pc/pack"
-LICENSE="unRAR"
-
-DEPEND="virtual/glibc
- app-arch/unzip"
-RDEPEND="virtual/glibc"
-
-src_compile() {
-
- make -f makefile.gcc || die
-}
-
-src_install() {
- dobin unrar
- dodoc readme.txt license.txt
-}
diff --git a/app-arch/unzip/files/digest-unzip-5.41-r2 b/app-arch/unzip/files/digest-unzip-5.41-r2
deleted file mode 100644
index 2536905fc2f6..000000000000
--- a/app-arch/unzip/files/digest-unzip-5.41-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d5fb7ca068da949765abb8c6bc71666e unzip541.tar.gz 1040190
diff --git a/app-arch/unzip/files/digest-unzip-5.42 b/app-arch/unzip/files/digest-unzip-5.42
deleted file mode 100644
index 44a34ee9acf9..000000000000
--- a/app-arch/unzip/files/digest-unzip-5.42
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4fc23bb7f3fb00ef6af35c5e77ede016 unzip542.tar.gz 1070770
diff --git a/app-arch/unzip/unzip-5.41-r2.ebuild b/app-arch/unzip/unzip-5.41-r2.ebuild
deleted file mode 100644
index 9a35413d5cf5..000000000000
--- a/app-arch/unzip/unzip-5.41-r2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.41-r2.ebuild,v 1.6 2002/07/17 20:44:57 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Unzipper for pkzip-compressed files"
-SRC_URI="ftp://ftp.freesoftware.com/pub/infozip/src/unzip541.tar.gz"
-SLOT="0"
-HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
-LICENSE="Info-ZIP"
-
-DEPEND="virtual/glibc"
-KEYWORDS="x86 ppc"
-
-src_compile() {
-
- cp unix/Makefile unix/Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
-
- try make -f unix/Makefile linux
-
-}
-
-src_install() {
-
- dobin unzip funzip unzipsfx unix/zipgrep
- doman man/*.1
- dodoc BUGS COPYING History* LICENSE README ToDo WHERE
-
-
-}
-
-
-
diff --git a/app-arch/unzip/unzip-5.42-r1.ebuild b/app-arch/unzip/unzip-5.42-r1.ebuild
index 290264ee9e1f..bf3ee1454493 100644
--- a/app-arch/unzip/unzip-5.42-r1.ebuild
+++ b/app-arch/unzip/unzip-5.42-r1.ebuild
@@ -1,40 +1,37 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.42-r1.ebuild,v 1.5 2002/07/17 20:44:57 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.42-r1.ebuild,v 1.6 2002/07/25 14:47:35 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Unzipper for pkzip-compressed files"
SRC_URI="http://soft.ivanovo.ru/Linux/unzip542.tar.gz"
-SLOT="0"
-
HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
+
+SLOT="0"
LICENSE="Info-ZIP"
+KEYWORDS="x86 ppc"
DEPEND="virtual/glibc"
-KEYWORDS="x86 ppc"
src_compile() {
- cp unix/Makefile unix/Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
+ cp unix/Makefile unix/Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
- case $ARCH in
- i?.86) TARGET=linux ;;
- *) TARGET=linux_noasm ;;
- esac
+ case $ARCH in
+ i?.86) TARGET=linux ;;
+ *) TARGET=linux_noasm ;;
+ esac
- try make -f unix/Makefile $TARGET
+ make -f unix/Makefile $TARGET || die
}
src_install() {
- dobin unzip funzip unzipsfx unix/zipgrep
- doman man/*.1
- dodoc BUGS COPYING History* LICENSE README ToDo WHERE
+ dobin unzip funzip unzipsfx unix/zipgrep
+ doman man/*.1
+ dodoc BUGS COPYING History* LICENSE README ToDo WHERE
}
-
-
-
diff --git a/app-arch/unzip/unzip-5.42.ebuild b/app-arch/unzip/unzip-5.42.ebuild
deleted file mode 100644
index 0dd0a14f6fef..000000000000
--- a/app-arch/unzip/unzip-5.42.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.42.ebuild,v 1.9 2002/07/17 20:44:57 drobbins Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Unzipper for pkzip-compressed files"
-SRC_URI="http://soft.ivanovo.ru/Linux/unzip542.tar.gz"
-SLOT="0"
-
-HOMEPAGE="ftp://ftp.info-zip.org/pub/infozip/UnZip.html"
-LICENSE="Info-ZIP"
-
-DEPEND="virtual/glibc"
-
-KEYWORDS="x86 ppc"
-
-src_compile() {
-
- cp unix/Makefile unix/Makefile.orig
- sed -e "s:-O3:${CFLAGS}:" unix/Makefile.orig > unix/Makefile
-
- try make -f unix/Makefile linux
-
-}
-
-src_install() {
-
- dobin unzip funzip unzipsfx unix/zipgrep
- doman man/*.1
- dodoc BUGS COPYING History* LICENSE README ToDo WHERE
-
-
-}
-
-
-